Download

Volumetric Cloud - Low quality reflection

Hi guys,
I tried to search in the documentation but nothing.
I have the volumetric cloud in my scene and I know the settings to work on the quality but I can’t solve the problem of the quality of the reflections. If I use an HDR no problem but with the volumetric cloud and sun/sky, no solution so far.
Can you help me please?

In the attached image you can see the ground reflections are good, the clouds are the problem.

The volumetric cloud actor has a reflection sample count

Reflections use the skylight capture, you can increase the resolution by changing the cubemap resolution option in the skylight.

It looks nicer, thanks! But as you can see even with 4K res the quality doesn’t look good enough.
Are there other parameters influencing the result?
Many thanks

The only other one I’m aware of is “r.SkyLight.RealTimeReflectionCapture.TimeSlice”, by default it is set to 1 which makes for very choppy animation. If you reduce it to 0 it will capture every frame.

Unfortunately that’s all I’ve got. If you’re lucky, Seb will chime in with a more definitive answer on how to overcome this.

If you have fairly static clouds my advice would be to capture the scene using a capture cube actor then convert the render target to a static texture and just use that as your skylight texture. They won’t move, but the color/detail will be more accurate. When combined with SSR you can get really nice results this way, even if it is a little disorienting upon inspection.

Here’s a scene capture cube result combined with SSR:

Unfortunately the skylight will only take a static texture as input and I’m not entirely sure you can have a render target continuously update a static texture at runtime, so I don’t know that there is any way to get this to animate in real time.

From the image above, the only thing missing IMO is increasing the sample count in reflections on the cloud component as mentioned by @Arkiras above. And you can remove the upper sample count limit by tweaking r.VolumetricCloud.ReflectionRaySampleMaxCount. Just be careful: high resolution sky light with more will lead to higher cost.

Appreciate the response, raising the max samples for reflectiosn worked great for me, however I do have one minor problem with the sun: It’s not occluded by clouds in reflections.

Solved. Cast shadows for clouds need to be enabled in the directional light. Figured this out when I noticed the TOD map didn’t have the same problem. :slight_smile:

[SPOILER]

Is there any way to solve this?[/SPOILER]