Volumetric Cloud crash on Android Vulkan SM5 Desktop forward shading

Hi, I am currently working on getting a volumetric cloud onto high-end mobile devices. However, encountered this issue where the app would crash with a blank level with just a volumetric cloud in it. This is the error I get from the call stack:

LogPlayLevel: 08-02 22:22:33.054 31046 340 D UE4 : Assertion failed: BatchElement.PrimitiveUniformBufferResource [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/Renderer/Private/ShaderBaseClasses.cpp] [Line: 543] LogPlayLevel: 08-02 22:22:33.054 31046 340 D UE4 : FRenderVolumetricCloudVS expected a primitive uniform buffer but none was set on BatchElement.PrimitiveUniformBuffer or BatchElement.PrimitiveUniformBufferResource

[This is the full log file][1]

[This is the shader code generated][2]

I have also tried to run the same setup on ue5 since they did modify the code in VolumetricCloudRendering.cpp a bit, still not getting the cloud to show. And it gives different error relate to [Vulkan RHI][3].

Digging in to the cpp file, I found out that ue4 version has set the primitive uniform buffer to nullptr where ue5 actually assigns an Identity uniform buffer to the slot, which could be causing the crash. I am wondering what can be done to get around this error.

Here is the comparison on the primitive uniform buffer setup