Download

Viveport, how to prepare ? Manifest,Path and other.

Hi all,
Does anyone have experience how to prepare Build for Viveport? They want a different directory structure other than the default. Three times I tried uploud according to the manual, but failed.
I am mailing with them, but I’m not sure their information is up to date and correct for UE4.

Report examples from Viveport submission team:

  1. Viveport PC application cannot start your game correctly. The executable file of your game isn’t place in the correct path. It should be placed in appname\Binaries\Win64, where “appname” is replaced by the name of your app.

  2. I got crash repot with following steps:

a). Pressed the system button on controllers during the game.

b). Closed the game from the menu.

c). It showed the crash report.
  1. The Viveport PC application will start your game/app according to the content manifest file. In order to launch your content correctly with Viveport PC application, you are required to place your main binary in appname\Binaries\Win64, where “appname” is replaced by the name of your app.
    If you complete your project by Blueprint, there won’t be a “Binaries” folder containing the executable file in the path which I mention before.  “appname\Binaries\Win64”
    Therefore, you should refer to following instructions to create your build again. Then you will have your executable file in the correct folder.

<Step 1>
In Unreal Editor, Go to File> Add Code to Project.
<Step 2>
You will see the panel “Choose Parent Class” and add this class “Actor” into your project. Of course it’s a dummy class just to create the “Binaries” folder containing the executable file in the correct path we need.
Then, you can rebuild your content and submit it again.

I tried all possibilities, but 3x failed. My build have no problem on Steam with the default file structure. Have someone the exact procedure steps?

PS: Very sorry for my bad english :slight_smile:

You ever get this working? I just submitted my game today and I know it will get kicked back for the directories issue.