Download

Vive + VR Preview Screen Resolution

The default screen resolution in VR Preview results in a blurry image on the Vive. Does anyone know what the optimal settings are for a sharp image? Thanks!

We are not seeing blurry images. Make sure under “Settings/Engine Scalability” all is set to Epic. Material quality should be high.

Thanks for the response, Jeff. Everything is set to Epic and Material quality is set to high. Is there a way for me to output the current resolution via the console while the game is playing?

I don’t know answer to that. Sorry.

No, sorry. But maybe you could try to force a reset of the internal screen resolution with ‘hmd reset’ or ‘hmd pd 1’.

Check to make sure that you don’t have the temporal AA enabled in your post process volume (under “Misc”). Try using FXAA instead… that should do the trick.

edit: Also, you can try executing a console command in your level blueprint to increase the screen percentage with “r.ScreenPercentage 150”. You will have to scale the number to suit your frame rate but that should also help decrease the perceived blurriness.

Hope that helps and good luck with your prj!

Thanks for the input! I’m not really noticing a difference though. (I changed this in the project settings. I’m new to UE4, so maybe I need to set it somewhere else?)

Is there a way to confirm that these commands execute properly? Whenever I input any of the commands at https://docs.unrealengine.com/latest/INT/Platforms/VR/CheatSheet/index.html, they don’t seem to work. Commands like “stat fps” are functioning however. Thanks for the help!

I would recommend creating commands that execute from within the level blueprint to handle these settings. Here are some examples:

Check this doc for details on each of these settings:

Oh, and you can view the output log to see if the settings are working by clicking on Window>Developer Tools>Output Log

Good luck!

We did just find out from Epic there was a bug where the VR Preview wasn’t running at 2160x1080. It defaulted to 1280x720. That explained why we were seeing a big framerate drop in standalone. But the image quality was better.

Here is the CL from Epic to fix.
https://github.com/EpicGames/UnrealEngine/commit/ebbb6da66e73446e03275857aa4b68394de14431

Thanks a lot for posting this info Jeff! This seems to definitely be the source of the blurriness in preview mode and explains the lower framerates in stand-alone builds that people have been experiencing.

Is it still a current issue in 4.9?

It’s been fixed with the recent preview updates (I believe preview 3 and higher).

The link is dead! I still have the same issue!

I’m having sort of the same problem. Everything looks fine in the editor but looks blurry in the packaged version.

anybody fixed it? and i have the same issue, and im dying to setting him

Did anyone ever find anything out with this? We’re on 4.12.5 and seeing the vive resolution appear to be much lower in packaged builds than when just playing in editor.

We found that adding the console command ‘r.setres 2160x1080’ in the level BP fixes this issue for packaged builds. But when playing in editor this makes for a giant monitor view window if we have this set so high.

Omg, I’m having this exact same problem and it’s so **** annoying! I’ve set the screen percentage in several different places now, based on answers found on the forums. None of them work! I just tried using r.setres but now the camera tracking is completely bonkers. Changing it in the post-process volume causes the “VR eyes” to go completely bonkers.

I wrote up some of my problems with this here in case anyone wants to chip in: https://forums.unrealengine.com/showthread.php?119540-Unreal-4-is-becoming-one-giant-convoluted-monster&p=577349#post577349

Minos, your forum link isn’t working. FWIW, I also experience the eye misalignment in the Vive when setting Screen Percentage to anything other than 100%. I’d really like to be able to use super sampling to get a crisper image in the Vive, especially when using TemporalAA, but that’s not possible if we’re restricted to 100% Screen Percentage.