Vive VR Locomotion Blueprint suddenly stopped working


Pretty new to Unreal and to developing VR projects in unreal so idk if i’ve broke something or messed something up in my blueprints but I recently used a tutorial to use the Vive controller trackpads for locomotion movement in VR. After completing the tutorial, I tried it out and movement worked fine until I grabbed an object. After some snooping, I found out that it was the hand collider section in the BP_Motion Controller blueprint was causing issues and to remove or disconnect it. I did this and everything functioned smoothly. Next day, however, my movement setup in the motion controller pawn blueprint has stopped working completely. Rotation bizarrely still works but moving in any direction no longer works. Controllers are functioning properly and the inputs haven’t been messed around with or changed, and i have no idea what’s caused this. The movement still worked after removing the hand collider portion of the motion controller blueprint the previous day so i dont know if that would be the cause but i could be wrong. I’ll attach my blueprint and inputs below to view as well as the tutorial in case anyone is looking for a good tutorial on setting up locomotion. Thanks for reading and any help provided as well :slight_smile: