[Vive] UE4 VR Preview Causes Red Screen issues!

I have some very anooing issues with the VR Preview in unreal engine.
Everytime i start the VR Preview the window pops up offscreen, overlapping with the SteamVR compositor and causes red screen issues. The only solution i found right now alt tabbing to the VR Preview window and pressing win+left until the window comes back from offscreen, then i have to go with my mouse offscreen and click inside the SteamVR compositor. Performing these tasks everytime i would like to run the VR preview is a bit exhausting, anoing and unnecessary.

Is there any way to force Unreal Engine 4 VR Preview window to pop up on the left screen and avoid overlapping with the SteamVR Compositor?

Hi Azarus,

Well, first of all man, you are my lifesaver !!. At least with the wn+left solutions I can test :slight_smile:

Do you have found a better way to solve this problem ??

Anyway, again, thanks so so sooo much for the win+left solutions

Best regards,

Yes, Reinstall the Video Drivers, and update it to the latest. some of the updates contain a fix and you can use the vive in direct mode, so the vive will no longer act as a display.
I had my vive running in extended mode and after makin the switch to direct mode everything is fine.

It was a driver and vive setup issue, In case someone runs into this issue, simply enable direct rendering in steamvr settings.