Vive Motion Controller No Visible Mesh,Vive Motion Controller No Visible Mesh

I’m new to UE4 and I’ve been working to get Vive VR going using the UE4 documentation. HMD is working (following: ‘Set Up a Seated Camera for SteamVR’), but the motion controllers (following: ‘Motion Controller Component Setup’) are not. I wrote a blueprint to confirm they are attached, enumerable, and being tracked. Using Print String node I’m logging their position and rotation to the screen on event tick, so I can see the values change in real time as I move the controllers.

  1. I’ve tried using the visualization tab of the motion controller component with the default and a custom static mesh.
  2. I’ve tried with a static mesh component nested under the motion controller component.
  3. I’ve disabled gravity, (physics is greyed out and can’t be enabled) to avoid scene clipping.
  4. Confirmed the host pawn is possesed by player 0 and that the motion controller components are bound to player0.
  5. Confirmed rendering is visible and that the position vector being logged is correct.

I’m at a loss. When I use the menu button the SteamVR menu loads and the internal models of the vive controllers appear attached to my hands. The static mesh that should be attached also becomes vivisble, located at [0,0,0] and unresponsive to controller movement, then disappears if I close the menu. The VR template works for me but I can’t see any differences between the settings for it’s pawn or mine albeit they spawn the motion controllers dynamically while the UE4 documentation has them attached in the editor.

Two days in to trying to fix this one issue I’m out of resources to read, videos to watch and things to try. If anyone can help, I’d really appreciate it!

What version of the engine are you using?

There was a bug in version 4.24.2 that I ran into, that sounds like the same problem: Unreal Engine Issues and Bug Tracker (UE-86988)

They’ve fixed it in 4.24.3+, but I had to re-create a couple of things and clear out the cached version of the build to get it to work.

I’m on 4.24.3 going to try updating to 4.24.4 soon. I see from the ticket you opened it the problem is identical albeit it’s still not working in my version. I was never running anything lower than 4.24.3 (total newbie) so I’m guessing there’s no need to re-create the project or refresh the cache. My only work around so far is to forego the MotionController component entirely and instead update the location and orientation of a static mesh using a blueprint attached to the event tick in the pawn.