Visual studio won't debug/build

I’m running Unreal 4.9.1 with VS2013, but I have two problems. Firstly whenever I build the code in VS the project in the editor seems to not register any changes (playing the game in editor/standalone is exactly the same as before the build) until I use the compile button in the editor. This is a recent problem which only started happening a few days ago, but only happens in this project.

The other problem is that when I either try and attach the debugger to the editor through VS or when I try and run it through VS (a friend said using the run button with unreal editor closed was how he gets the debugger to work usually) I get an error stating that “The remote Visual Studio debugging monitor (MSVSMON.EXE) is not running” which makes it incredibly hard to debug. This happens in every project, so I’m not sure if theyre related or not.

I’ve tried refreshing the project and I have tried with different projects but I still have the same problem.

Hello btunnadine,

As for your first issue, have you tried upgrading a copy of your project to 4.10 with VS2015 to see if the same issue occurs? I’m curious to see if it is a project specific problem.

As for your issue with Visual Studio’s debugging, this could be an issue with VS itself. You can find more information about that particular error at the following link. The “I got this message while debugging locally” section may be the most helpful from what I see.

Thank you for the response. I’ve just tried the project in 4.10 with VS2015 and it works perfectly fine, it used to work with my old setup as well, I’m not sure what changed though. Unfortunately I can’t work using 4.10 otherwise I would. Maybe I could simply delete the VS project and let unreal make another from scratch? I’m not sure if it is the VS project settings or Unreal’s project settings causing the issue but I’d think it is one or the other.

I also tried some of the fixes in the link, and some similar pages within msdn’s website but with no luck. I even tried forcibly running MSVSMON.EXE, though nothing really seems to help in that regard.

Well with a little more fiddling with the old 4.9 project I managed to get the building and hot reload working. Thankfully the updated project was working fine so I just copied over some of the working settings, though I’m not sure what the actual fix was.

Another note on the debugger, though. If I disable my firewall it does seem to make the error message saying MSVSMON.EXE is not running appear quicker, though I’m not sure if this is progress or simply a side effect of attempting running a remote debugger without it being checked by a firewall.

I’m glad you were able to fix your first issue. As far as fixing the second one, I’d suggest checking any security software you may be using to ensure that msvsmon.exe isn’t being blocked.

You could also give a try to running it manually, if this isn’t what you tried before. To do this, you can open “Run” from the Start menu and enter “C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\Remote Debugger\x64\msvsmon.exe” if your Visual Studio is in the default install location.

If neither of those help, I would suggest reinstalling Visual Studio itself to see if that may help.

A side note: As far as deleting the VS project when using UE4, that can definitely help at times. You can always regenerate a project as long as you have the .uproject file and the Source, Config, and Content folders. All you need to do is Right-Click the .uproject file and select “Generate Visual Studio project files”.

I’ve tried completely disabling my Firewall and Antivirus (as well as Windows Firewall) but to no avail. I can run the remote debugger (although from either the Visual studio 12.0 or 14.0 folders which I believe are 2013 and 2015 respectively) but having it running does not help the debugger attach. I’ve tried it on two different PCs and I have the same problem, though i may test it tomorrow on a third (not windows 10) to see if that makes a difference. If not I may try reinstalling VS but I feel that may help that much.

Well, the code works and I can debug on my University’s Computers (Windows 7, VS2013, UE4.9.2), so at least I can do it there. I’m not sure what the problem is on mine exactly. I read on another post that this might be caused by special characters in the windows username, and windows 10 uses an email as a username so i made a new local user, but it still does not work. Hopefully I can find a fix for my home PC, but at least until then I do have somewhere to debug.

If you have any other thoughts on what it might be that would be greatly appreciated :slight_smile:

I just noticed that we never tried reinstalling VS. Could you give that a try to see if it fixes the issues related to the debugger not working correctly? Otherwise, this may need to be taken up with Microsoft support as it seems to be related to the Visual Studio debugger itself rather than UE4. Have you tried debugging any basic projects without of UE4’s involvement?

I’ve tried debugging a couple of C++ console projects and the debugger attaches to Unity perfectly fine. I can try reinstalling VS, but I might not be able to do it for a couple of days as I don’t have the time to wait for the installer at the moment. I think you might be right, it probably is an issue with the debugger (or possibly a windows 10 issue).

Okay, after some more tests, I can debug any program (except unreal) in x86, but when I swap to x64 is when it breaks. As far as I have read this is because VS needs the remote debugger to be able to connect VS to the program (as VS is 32 bit) which is where the error is occuring. I’m not sure why it cannot connect though as there is no reason it shouldn’t be able to: With the remote debugger running and Firewall disabled there shouldn’t be anything stopping it.

Thank you for giving that a try, btunnadine. From what you’re saying it does still seem like a problem with either Visual Studio or Windows itself as the debugger is having trouble connecting. Could you try contacting Microsoft support to see if they can give any suggestions on fixing the issue? In the meantime, I’ll be marking this as resolved for tracking purposes alone, but please comment and let me know if you find out any solutions from speaking to them.

Hi Matthew.

i have the same problem with VS 2017 and UE4.17.1

I cannot start a new instance

I even added MSVSMON directory to be excluded by firewall and anti virus but it does not work

As I previously mentioned to btunnadine, this seems to be an issue on Visual Studio’s side rather than being related to UE4 itself. I would suggest contacting Microsoft support for further assistance.