Visual Studio doesn't find PDB files and doesn't load symbols

Hi!

I’m having multiple crash issues that I would like to investigate further, but when editor triggers a breakpoint, Visual Studio can’t find symbols for editor DLL. I added UE folder where they are located to PDB search paths and tried to browse for the specific .pdb but I keep getting this error:

“UE4Editor-CoreUObject.pdb could not be found in the selected paths”

I’ll be happy to provide additional information if neccessary. Any help would be much appreciated :slight_smile:

Question just for curiosity: did you click Load? I’ve had similar issues with Visual Studio in the past and sometimes just telling it to Load again is the fix it wants.

Yea, I’ve tried to hit Load couple of times. First time this screen appears, the red text isn’t there but when I click Load the red error text appears. Thanks for the tip though!

Look on log, “pdb does not match image” dll file is that image means that they are incompatible. So importent quastion here, how yoj got those pdb files? you compile engine from source?

Thanks @Shadowriver I had some issues when trying to build the engine so that’s why the files didn’t match the image!

I had the same problem now ,have you been solved this problem?could you please give me some hint

symbols don’t work for me either. I can set breakpoints in the engine, but not in my projects. The pdb file exists. I’m building DebugGame Editor. So what am I missing?