Visual Studio building a solution is stuck on Creating Library

Hello, im working with a team, and they are able to load and build the project, but on my computer (it was working before) i get stuck when building…

1>------ Rebuild All started: Project: ProjectX, Configuration: Development_Game x64 ------
1>  Cleaning ProjectXBinaries...
1>  Parsing headers for ProjectX
1>  Reflection code generated for ProjectX
1>  Performing 7 actions (4 in parallel)
1>  [3/7] Resource ProjectX.rc
1>  PCH.UELinkerFixups.UELinkerFixupsName.h.cpp
1>  PCH.ProjectX.ProjectX.h.cpp
1>  UELinkerFixups.cpp
1>  Module.ProjectX.cpp
1>  ProjectX.generated.cpp
1>  [7/7] Link ProjectX.exe
1>     Creating library C:\ProjectX 4.7\Binaries\Win64\ProjectX.lib and object C:\ProjectX 4.7\Binaries\Win64\ProjectX.exp

It just doesn’t get past that - any ideas ?
I’ve tried deleting the entire project and getting a working copy from the SVN we use -
Deleting the Intermediate and Recreating the Visual Studio files from Right Clicking the .uproject.

Hi, I am having this same problem. Did you ever figure out how to solve it?

Hey zerokewl and Pesk92-

Does VS freeze when building non-UE projects or building a new UE project without starter content? When building your project do you get the same issue when building in DevelopmentEditor configuration?

Cheers

Doug Wilson

Hi Doug. Thanks for the reply. I am in the process of moving house so I probably won’t be able to test more until next week. Haven’t tried building another project recently, so not sure about that. I get the same issue when building in developereditor conf.

Hey Pesk92-

I was wondering if you’ve had the chance to test the VS freeze on a new project or a non-UE project?

Hi Pesk92,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

This issue happens to me on multiple projects, often at the same point int he build.

Usually after UE4Editor-Advertising.dll, or UE4Editor-AudioFormatADPCM.dll, but sometimes after compiling Module.Core.6_of_8.cpp as well.

I’ve been battling this for months, frequently having to cancel builds, restart them. Sometimes, I eventually get a successful build, but running the editor will result in missing or outdated .dll modules, which I then have to delete and rebuild in order to get the editor actually running.

Hey hvs-

Can you let me know which version of the engine you’re using? Also, are you building a project or the engine itself? If you are using Incredibuild, can you make sure that it is updated to the latest version? Let me know if there is any other information you can provide.

When building the engine always. Currently on 4.12, but this has happened on earlier versions as well. I will verify the Incredibuild version is up to date.

We are on Incredibuild version 6.0 (build 1580).

Just upgraded to 7.1 (build1659). We’ll see if similar hangs occur.

It seems to be behaving similarly. Incredibuild shows Module.GoogleVRHMD.cpp taking a very long to compile. No other threads are active while this file is compiling.

Since the update I see a new error as well:

5>EXEC : Fatal error : A Xoreax distributed job cannot be started from within another distributed job.
5>
5>
5>ERROR : UBT error : Failed to produce item: D:\Develop\Tempo\root\UE4\Engine\Binaries\Win64\ShaderCompileWorker-Core.dll

The most recent version appears to be 7.2 (build 1699). Can you let me know if this version works for you? Additionally, if you’re using Visual Studio 2015, can you check if you are on Update 1 or Update 2? You can find this in Help->About Microsoft Visual Studio.

In reference to the errors, I have not come across what you’re reporting. After downloading the source code you ran Setup.bat and GenerateProjectFiles.bat correct? Can you check that your solution configuration and solution platform are set to DevelopmentEditor and Win64, respectively?

I used the Incredibuild updater to grab the latest version automatically. Not sure why it would have only gone up to 7.1 then. I will see if I can grab 7.2.

Visual Studio 2015 at Version 14.0.24720.00 Update 1.

Yes, I recently updated to 4.12.3 and after merging the changes in I ran Setup.bat and GenerateProjectFiles.bat. This sort of thing has happened periodically even before this update though.

Definitely building Development Editor Win64, with our project set as the Startup Project.

These issues appear to be resolved after fully uninstalling Incredibuild.