Visual Studio 2017 Issue

My problem is that I am willing to learn c++ , but cannot edit a singel file with ue4!
So, I donwloaded Vs2017 ,had ue 4 before that. The onstallation should be straight forward- select for desktop option and for gaming. Specifically selected also windows SDK 8.1 , not ue installer.(had it) now I think I’ve set up everything regarding c++ for gaming. I start vs, could make a project ,run it in the console-fine. Now I go to the ue4 launcher. I start a new project. First blueprint-new c++ file-generating-ERROR 32 bit toolchain not found. And the same when I try to generate a new C++ ue project from the library. Epic says it’s supported since 4.15 and i’ve tried it with that version as well. Uninstalled 2017 everything again. Whyyyyyy I tried everything. Don’t come with me with VS2015 itried that too. Wasn’t able to install c++ toolset with that and so on. I need a simple solution for 2017. Why does it have to be so complicated. A step by step instruction would be perfect. I am very thankful for a solution.

The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files/Epic Games/UE_4.17/Engine/Binaries/DotNET/UnrealBuildTool.exe cpper Development Win64 -project=“C:/Users/A/Documents/Unreal Projects/cpper/cpper.uproject” -editorrecompile -progress -NoHotReloadFromIDE
Performing full C++ include scan (building a new target)
Creating makefile for cpper (no existing makefile)
@progress push 5%
Parsing headers for cpperEditor
Running UnrealHeaderTool “C:\Users\A\Documents\Unreal Projects\cpper\cpper.uproject” “C:\Users\A\Documents\Unreal Projects\cpper\Intermediate\Build\Win64\cpperEditor\Development\cpperEditor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed
Reflection code generated for cpperEditor in 13,2737006 seconds
@progress pop
ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe


Just dont start VS before.
Start the epic launcher and create a new c++ project. Then it will autostart VS. Be sure you have all tools you need in VS 17 if not it will show you.

I updated my issue. I tried it like you said. Still error
When i press Open VS it says:

Could not edit the code editing IDE. C:/Users/A/Documents/Unreal Projects/cpper/cpper.sln could not be found.

Maybe you need VS 2015 to open it. That solved alot of my probs

I don’t know why but after a normal Windows update the error dissapeared. It is very strange cause i did’t Change anything form last time. it launches VS 2017 and it can run changes i make in c++ tutorial Projects.