Visual Studio 2010/2013 conflict

When I create a new C++ project Visual Studio 2010 automatically starts telling that, of course, the project isn’t supported. Is there a .ini or config file where I can specify the Visual Studio 2013 path?

Hey Habaki,

If you are using the GitHub version of UE4, please see this post about where to change the setting for which compiler the editor uses:

If you are using the Installed/Launcher version of UE4, please let us know.

Edit: To clarify, this is the solution if the UnrealBuildTool is defaulting to use VS 2010 instead of 2013. If this is not the accurate description of your problem, please reply and provide further detail to the steps you are taking to hit this error and also provide a screenshot of the error message you are getting.



Hi Steve,
Thank you for the answer, I’m using the Installed/Launcher version of UE4.
I’ll try with the GitHub version today.
How do I check UnrealBuildTool default?
The steps are:

  1. Launch 4.0 or 4.1 from the Launcher.
  2. Create a C++ project.
  3. When the Editor reload to open the project VS2010 automally starts.


Once you’ve generated a solution file (the .sln), when you right-click on it do you get the option to open in VS2013 instead of VS2010?

I’m having a similar problem. I actually have VS2005, VS2008, VS2010, VS2012, and VS2013 all installed on my machine. Guess I am too lazy to remove them.

In any case, I cloned and built UE4.3 and launch the editor just fine. However, whenever I created a 3rd person camera code project, it booted an instance of 2005 and crapped out on an error.

How do I force Unreal to associate VS2013? Btw, I’m currently using Express for Desktop.

Okay I figured out how to solve it. Bit of a face palm. After uninstalling 2005, 2008, 2010, and 2012 (leaving 2013), instead of launching the wrong Visual Studio, it would simply not launch at all (no error, no feedback). So I actually went and uninstalled VS2013 Express and reinstalled it, reinstalled Unreal Engine and still nothing.

The easy way to fix this is to right click on the project in Unreal Engine and go to explore. Then right click on the sln file and set “Open With” and point it to Visual Studio Version Selector. And then that fixed it for me.