Visual garbage in cooked / packaged build (4.12.3)

Hello everyone,

we’ve ran into a very strange issue while packaging the game.

This is a PIE screenshot:

This is what happens when I run packaged build:

I tried to erase terrain, foliage (as it looks like a distorted tree or something) but to no avail. Interesting is that it’s happening only in the very first level and as soon as the rest is streamed, all glitches disappear.

I also deleted whole intermediate folder to eliminate possible problem with bad material.

Could you please point me at what to check? I tried to hunt something down in cook log, but never found a real cause (especially given the fact that the same assets work in other levels well).

Thank you!

I ran into a cimilar issue once. Maybe your textures are not packaged? try re-assigning the textures to the materials that have this issue, then repackage it. it’s a temporarily fix.

Hey metamorphium,

This almost seems like the textures just need to be loaded into memory and streamed into the full resolution. How does this level begin? Is that a loading screen or another way of allowing the textures to load first before jumping into the car and driving? Sometimes games use these things to hide textures loading into their level and initializing.

You could try typing ‘Stat Streaming’ into the console command to list all the current streaming textures and view the current memory pool limit.


Andrew Hurley

Hi Andrew,

thank you very much for your response. The actual situation is, that we do have a sequencer which starts with a widget for a few seconds and then it’s a hard cut into the level. I believe your pointer is definitely worth checking. Is there a way how can I check if level has been actually loaded? I could simply wait until it’s loaded and then hide the widget - which would also check your theory.

It’s combined C++ / BP project so anything works.

Thank you!

Hello again.

I’ve tried the following:

  1. let sequencer pause right when the level is loaded and wait 1 minute to see if anything loads. Unfortunately it didn’t work. Garbage is still there and it’s random. Almost looks like a memory spill. Also what actually happens is that the road (I mean the highway surface) at the very beginning looks correct and after some time the surface disappears and is replaced by an opaque color. Those weird polygons at the back are there always and every single time I run the build they have different colors and shapes.

  2. I used Stat Streaming and this is the result. In my opinion it’s not a streaming issue after all (or at least I can’t see any problem there).

Is there anything else I could check, please?

Thank you. I will try this and see if that helps.

Ok. So we narrowed the culprit down to a SpeedTree model. Still don’t know why, but when we deleted all trees from Foliage, the problem disappeared. We’ll try to track down the actual model.

Funny thing is that it doesn’t happen in editor so it must be something which happens while cooking.

Let us know if you need any additional assistance.