Viewport behaves irrationally

I’m updating this post to reflect my current status. I’m using a windows pc running Windows 7 and I noticed my issues on the 4.9 version, but it seems to be affecting older versions as well.

So Last night while I was browsing through Chrome I was rendering a scene. When it was done I wanted to check it out and I could not click on anything in the 3d viewport. I didn’t know what to do, so I went through the settings, unknowingly I might have enabled something.

Around the same time my viewport would rotate upwards slowly until it could not anymore and then shifted to the left side. I restarted my pc and verified the engine files. After that the mouse seemed to stop, but only for a short while, soon it would pop back.

At this point I opened a different project on a different engine version (4.8) So I closed the engine and plugged in my mouse into a different port, this seemed to have done something as it stopped the axis movement from rotating upwards.

Yet I couldn’t click on anything, so I tried double clicking, which was successful. After closing the engine and searching for known issues like this I ended up with nothing. I again restarted my project and then instead of rotating, my 3d viewport is now constantly moving to the right.

And this is my current status.

I tried to search for answers but I have yet to determine where this is coming from. I am considering faulty hardware, but everything else is working properly. I can play games, load up other 3d software with 3d vewports (Tried Blender) and I am not experiencing any issues anywhere so far. The issue Seems to be explicitly affecting my 3d viewport in the editor. The other viewports are working per usual, can select object with one click and work in them as usual.

But It still makes working in any project useless, since my 3d viewport will constantly move away, so I can place or select things in there, I cannot even focus on one area.

I hope I can get to the bottom of what is actually causing it, I am thinking of completely reinstalling the engine to see if that makes a difference. Maybe it’s an internal conflict within windows itself? I would really be grateful for some help. Right now I’m at a loss and unable to continue working on any project…

Sooo, the fix? DO NOT INSTALL FreeMake… I had the utility installed ages ago, before working in UE, but somehow it kicked into high gear and messed up a part of the unreal engine in ways I cannot even phantom.

Spent the last week trying to figure out what the cause was, and finally ESET called out on this being malware/pup and got rid of it. I’m leaving this here if anyone ever has the same issue, I hope I can save them countless hours trying to wrap their head around the it…