Download

videos are not playing in packaged project

Hi
I have some videos in my level (wmv 30fps 640x360) and inside the editor (engine 4.9.1) it works well.
But in a packaged project all surfaces with videos turn into black.
I have tried different paths, folders, different video formats etc, with no success. I also switched from default lit
to unlit in the material, only emissive, both base color and emissive, always the same.
Then I loaded an old project, I guess 4.6, in the 4.9.1 engine with a video inside: Same result:
In the editor it plays well, in the stand alone packaged game not.
Any ideas?
Thanks a lot.
Chris

Take a look at this thread: https://forums.unrealengine.com/showthread.php?58257-Video-Texture-not-showing-in-Packaged-version-of-game :slight_smile:

I did exactly what is described in the thread, the result is the same: video is playing inside the editor, black or worldgridmaterial in a packaged game.
Am I the only one who want to use videos in a game? :confused:
Again: currently I am using engine 4.9.1. An older project from me using engine 4.7 works well with videos in a packaged game.
Any advice?
Thanks again
Chris

I have used videos (as texture on a TV) in two different 4.8 projects. Haven’t tried 4.9 yet. It packages and plays correctly on iOS, Android, and Windows.
Here is the path I used for my Media Player: ./Movies/Solaire_Movie.mp4

And it absolutely needs to be in the Movies folder. Someone somewhere said that it needs to be a certain codec, so try compressing as h.264 or mpeg and see if it makes a difference.

I was having problems with Autoplay/looping, especially on iOS, so I made this auto-looper in the level blueprint with the exact length of the movie.

https://forums.unrealengine.com/attachment.php?attachmentid=61642&stc=1

You are using mp4??? On Windows?
I have tried Quicktime h264 and mp4 but the media player always says “stopped”.
Only wmv works well…
A few months ago I finalized a project using wmv videos and all worked well in a packaged game.
So I am wondering if this is now so a huge problem for me.

Problem solved. The autoplay function is no more available in the current version, therefore all my videos are not starting automatically at levelstart.
You have to set up the function in the level blueprint, it is pretty easy.
See here:
https://docs.unrealengine.com/latest/INT/Engine/MediaFramework/index.html#mediaframeworkwithblueprints