Video / Media Texture stay black [Android]

Trying this in 4.11, still a black screen in a note 5 gear vr. Anyone got this working?

Hello
I also have a S7, a Gear VR and UE 4.11.1 and it don’t works at the moment.
I followed the instructions from Chris above exactly. I made a cube inside the first person example map for testing.
On the front side I see the default material grid instead of the epic video. On the back side
I have a second video for testing and here the surface is completely black.

Chris

Well, I used a sphere, reversed normals, and it works in the editor, but not in the phone.

I’m looking into the issue with GearVR movie playback problems. I have a workaround at the moment:

Create a UMG widget and add a tiny border in the upper left corner. Set the brush color alpha to 0.01 so it isn’t visible. Create and add it to the viewport in your level blueprint. This will make sure it renders something last. This cleared up the problem in our testing.

I tried that but i cant make it work. Am I doing something wrong?. I’ll attach a screencap of my blueprint

Hi JoseGuya,

Have you tried during off Gear VR and running it to see if the movie works?

The above level blueprint looks fine, but I usually add the widget first, not that it matters in this case.

I just tried to use a texture (bitmap) for the gear VR and it turns to black.
In the material I turned off use lightmap and turned on fully rough like Chris described.
But setting this to standard values in the material the texture appears.
Then I did the same for the video-material and voila, the video works right now.
It is a bit slower while the video is playing and it plays only one time instead of repeating (looping
is checked).

Ok, I don’t have the widget and use lightmap is off and it works.
I think it is the feature fully rough…
And it is still slower while video is playing (I took the epic video for testing)

Hi Flowmaster,

That is odd; unlit fully rought is working for me at the moment.

For looping the video I have to force it in the level blueprint with a looping node in between.

Setting looping on the player to true works for me, too. My current test project shows 2 looping videos on GearVR with unlit, fully rough.

By the way: I have problems creating my own mp4 video. Open an imported video in the media-player results in “not ready” or simply a black screen.
I have checked so many details from the epic video if I could. What editing software are you using? I tried Adobe Premiere CC and a free mp4 converter.

Both MPEG-4 and H.264 mp4 files should work on Android. Only MPEG-4 will work on PC, though. I believe we use Premiere; I’ll have to check with the video department. Does your mp4 play in the video player on the android device?

It’s not listed in this thread, but I saw in another thread that videos that work in the editor but not on Android (showing only a black screen) may be caused by the path for the video. That is, you want to use the relative path instead of the absolute path (which probably references your PC’s hard drive by default). Since your phone isn’t always connected to your PC’s hard drive, use ./Movies/[your video name] instead of C:\Documents\Unreal Projects\Content\Movies[your video name]. Let’s see if I can attach this photo correctly…
RelativePath.PNG

Hi Chris,

Thanks for the provided anwser. I’m currently having trouble to get the movies running in UE4, on a Samsung Galaxy S7 with the Gear VR. When applying a media texture to any of my objects, it simply does not play when packaged and run on my Gear VR. Do you maybe have any indication whether or not this will be fixed in a future iteration of UE4?

Many thanks!

When u say “voila, the video works right now”, u refer to the editor level or the gear VR headset for samsung galaxy? i’m having issues with this and i almost searched in all the web till i find your post…

hahaha thanks for your attention!

There appears to be a state caching issue with the movie player which is likely why messing with the material settings sometimes fixes it. I’m working on a proper fix.

Hi Arjo_5
I mean the Galaxy. I have packaged the game for the galaxy and tried it on the phone inside the gear vr.
In the editor it is always playing very well.

Hi Chris,

Following your suggestions I managed to make it work, now i see my video playing also on the mobile, thanks for that!

I have another issue now, not sure to what is related. I am mapping the video onto a sphere, mostly like everybody in this thread :slight_smile:
Everywhere in UE4 works perfectly, on the GearVR when i look downward (anyangle) is all fine but if i look upward (anyangle ) the video is not mapped correctly on the sphere, the uv looks like totally crazy.

Is like there is a virtual spherical trigger, as soon as i´m looking something on the upper emisphere the uv crash but get fixed when i look down on the lower emisphere

Some more info:

  • My scene is totally empty i have only a sphere and player start actor and nothing else.
  • The flipping does not happen randomly, it feels like there is an invisible trigger

Hope i could describe the issue because is quite strange :p. Any idea?

the uv issue appen only while the video is playing. Once it stop I can look anywhere and all look correctly mapped