Video / Media Texture stay black [Android]


I need your help with Media texture because when i play it on my Android, the texture stay black unlike my compiter. I try to export my video in wmv and nothing change.
I check the AutoPlay box

I really need your help

Thank you

Did you have any success with this yet? I’m struggling with the same problem

Hi guys,

I have the same issue on Android. I found this : Media Framework | Unreal Engine Documentation
where they say
"Currently a player plug-in for Windows is being used which uses the Windows Media Foundation API under the hood. There is also a plug-in for MacOS, which uses Apple’s AV Foundation, however it is currently quite limited but should work on iOS. Work has also begun on a player plug-in for Android. "

MP4 movie playback for both startup movies and the Media Player are supported in 4.7 with Android 4.0 and higher.

Here are the steps to make a simple test project:

  1. Create a blank blueprint project set to mobile with no starter content
  2. Right click on Content and create a New Folder called Maps
  3. Right click on Content and create a New Folder called Movies
  4. Open an Explorer window and find Engine/Build/IOS/Resource/Movies/Default_Startup.mp4 and copy it to your project’s Content/Movies folder as MyMovie.mp4
  5. Right click in the Content Browser and select Media Player in Miscellaneous
  6. Name it MyMovie and double-click on it
  7. Select the mp4 in the File browser and save
  8. Right click on the Media Player and Create Media Texture
  9. Right click on the texture and Create Material
  10. In Detail Mobile, turn off Use lightmap and turn on Fully Rough
  11. Connect texture output to Base Color and Emissive Color and save
  12. Drag the material onto the ground in the viewport
  13. Open level blueprint
  14. Drag off the Event Begin Play and add a Media Player Play node
  15. Drag MyMovie to the Play node target and compile
  16. Save the level as Entry into the Maps folder
  17. Open Project Settings and set Game Default Map and Editor Startup Map to the Game Entry map
  18. Package for Android ETC1 (or any format your device supports)
  19. Install on device and run

If you want to try startup movies, open the Movies section and click on the + on Startup Movies to add an element and expand it to select the MP4. It will play each movie in the array in order. If you do not check “Wait for Movies to Complete” the movie playback will stop as soon as the level is ready to render. Check “Movies are Skippable” if you want to allow the user to tap to stop the movie early.

As of today, with 4.7 source or binary start up movie work but “in game movie” dont. I tested it on galaxy S4 as well. (4.4.2 and Lollipop).

I think by “loaded movie” in the announcement thread for 4.7 it wasn’t meant to be “in game movie”?

Edit: I also created 2 new projects with third person template (one from source and one binary) which don’t work with the steps described above. Also the answer from samantha in answerhub says that in game movie playback isn’t possible yet on Android.

Edit2: Also the start up movie starts playing while google play is connecting or asking the player to log in. For connecting it might not be such a big hassle, but when asked to log in while a movie plays in the background, it might not be so ideal.


Startup movies definitely work in 4.7, but in-game using the Media Framework should be working as well on Android 4.0+; the steps above plays in a texture and works on the devices I’ve tried. Which model Galaxy S4? I’ll try it here and see if I can reproduce the issue.

As far as Google Play goes, yes, I agree there is an issue at the moment since the current Google Play Game implementation tries to log in immediately instead of waiting for the game logic to initiate the log in. I’m talking to the appropriate people about a change to deal with this better.

Yeah, start up movies work.

Its GT-I9505 Galaxy S4 with Adreno 320. I know a device at the lower end boundary, so maybe it shoulnt be held as a refernce.

I will test it again on a Htc Max and again on my Android to see if I made some mistakes.

But again the answerhub thread I linked above makes me believe otherwise.

Yey, it plays now also in game.

Sorry for that missinformation.

I think the mistake I made was putting the movies folder not straight inside the content folder when I first imported the movie yesterday. Having the base mp4 in this folder is important like it has always been. Sry for that again.


Not a problem. Thank you for letting me know; the mp4 must be in your Project/Content/Movies folder to be packaged properly.

A quick note here for anyone having problems. I noticed on the PC, that the video is referenced by absolute path in the URL by default when adding the video to the folder. For example: “C:\SomeFolder\UE4Project\Movies\TheMovie.mp4”. This breaks the movie playback on the device. The URL should be something similar to “.\Movies\TheMovie.mp4” for it to work on all devices. (Note, I may be mixing up forward slash with backslash here)

I thought it did not work on my device either until I fixed that. :slight_smile:

This works for me if I apply the material to a static mesh, however if I apply the material to a UMG Widget nothing shows up on device and it often crashes.

Are there any methods to ensure UMG + Videos work on Android?

Cheers for any help


I made a tutorial video in my last update for Tako Tako using UMG Button Widget:

At least on my S4 it never crashes.

First check with the default video provided by epic. I think some video resolutions can crash or in my case don’t even show up. For my video I used the same resolution as the video from epic.

Then check that u used the emmisve channel.

Also check that u used to show the material as a image not as a box (in the button widget style settings).

Test it first with a 3rd person template or something, there is actually some stuff like remove widget nodes which can crash the game when used at wrong place. (which I have to fix in my next update :slight_smile: )

GearVR Framerate Issues with 360 Video

Hey everyone,

We’ve been going back and forth with Unreal and Unity to try to create a 360 video viewer app for Gear VR. Unreal is BY FAR easier to set up and get going (Unity 5.1+ is getting better). We have the movie sphere playing just fine, and everything is working, but the biggest issue that we are seeing with Unreal is the framerate. We have a 20 MB .mp4 that we are playing that is 2048x1024 and 50fps. It plays perfectly in the editor at 50 fps. However, in the GearVR we are getting maybe 5-10 fps, which is no good when it’s a high-motion video. Does anyone have suggestions as to why the framerate is so low in the APK? I assume it’s the GPU processing power in the phone (Note4) vs. the computer. Unfortunately, We are going to have to go with Unity if this won’t be fixed until 4.9. It’s very unfortunate that support for large videos is not a bigger priority, since a large portion of the VR apps that are being dev’d are for showing off 360 video. Hopefully this gets some love ASAP from Epic. Again, if there is a way to fix the framerate, I’m all ears. Thanks.

Barry Zundel

Hi bzundel,

Please see this forum thread for how the movie player currently works:

For now, lowering the resolution of the movie is your best bet. I won’t get a chance to look at improvements until 4.10.

Thanks, . I’ve already cut the video resolution in 1/2 to 2K, and 1K is not going to give us the resolution that we need to have it look good, so I guess Unity is going to have to be the answer (unfortunately). If I could put my vote in to move this up on the priority list, I would do it. There seems to be a lot of discussion about this being a big problem with Unreal. It’s a shame that setting up a 360 viewer in Unreal is so incredibly easy, yet the content has to be low quality to have it work as needed. If it could get pushed up, that would be immensely helpful! Thanks.

Barry Zundel

The feature set for 4.9 is already locked and only correcting bugs is the priority; Preview 1 was released yesterday:

is this fixed in 4.9.1?

Hi denlittlstar,

No, it is not in 4.9.1.

Hey guys,

I’m working on my BSc project which is cinema app for Gear VR. Using UE 4.9.2, Samsung Galaxy S6 with 5.1 Lollipop I developed simple app but have some issues here:

  • If I pin Play node to other event than Begin Play it is not working.
  • When I use Open Url and then play it works but only once (I have a sample 5 sec demo video).
  • It seems that OnMediaOpened(MediaPlayer) event does not triggers at all despite open url worked fine (that one time).

I’d appreciate any help!

I know it is a bit off the topic but can anyone tell me if it’s possible to convert movie into proper video format via VLC to be playable in such project? I’ve tried various configurations for hours but either quality is really poor or sound is terrible.

Thanks in advance!

I’m having issues in 4.10 same with the Black Screen…(Galaxy VR Gear S7) - 360Video

Going to try on 4.11 in a short while…

Really hope it works…as I need to do a High profile job with it…and be portable !!! (I don’t want to have to switch to Unity) !!!

Anyone else seeing this issue