Download

Video media texture seems still not working after 4.12.2 hotfix

Resolved.

Scroll down to #12 to see the resolution.


Hi,

I have just updated to 4.12.2 n check if the video background would work in the standalone game.

I added an UMG for my game which includes a video background and a menu, the whole thing works in Editor preview but everything is black in Standalone game in 4.12.0. In 4.12.2, everything is also visible in Editor preview. But in Standalone game, the menu is visible but the video still stays black.

Are there any other ways to fix this?

Thanks.

I’m currently experiencing a similair issue. I’ve applied a video as a skybox in my project (360 video for GearVR), and after 3 seconds, the whole thing glitches. 4.11.2 was working fine for me.

are any developers here? is there any further fix for this issue?

I had this problem with one of my projects. Try opening up your media file and click or reset the url that it is looking for the video. I noticed that it was referencing it from the projects still and not the build. This worked for me so hopefully it works for you too!

hey thanks for ur reply, but i m not sure wt you mean by “referencing the project but not the build”.
In the meantime i have tried to copy and paste the wmv file directly into the folder /Content/Movies. I try to recreate media player, media texture n material. Doesn’t work either.
a new uasset is created in the folder, but it still doesn’t work

can anyone help me please?

https://answers.unrealengine.com/questions/134684/problem-on-embedding-video-media-texture-when-publ.html

please also look at this thread if any unreal developers are here…the media texture still doesn’t work in 4.12.4 but 4.11.2…

"I got the path updated to relative, but packaged videos are still a black texture. Has this worked for anyone else?

EDIT: I just tried streaming the file from my website, and that isn’t working, either. No luck with Shipping, Development, or Debugging packages. File was originally 1920x1080, but I’ve tried it with 1918x1078 (lol) to no avail as well. .wmv file

EDIT2: Works fine in 4.11.2, but not 4.12.3"

I guess that you need to build a Bp to control the MediaPlayer, Maybe you don’t Open the MediaPlayer.

bumpppppppppppp

ok i have found a way to resolve this

IGNORE THIS IT IS WRONG

update. it is still not working after the project is packaged, but work in standalone game n editor.

should work now this time. the previous one is wrong

simply solve it by using the event tick. don’t use event start.

Media Framework is currently broken, a fix is coming in 4.13 :smiley:

it should work now. i have tested it for packaging. it’s kind of confusing though.

I tested this out using 4.11.2 and it does not work in our package. :frowning: I hope that Epic will have a fix soon with their Media Framework

Hello,
It works for me with 4.12.5
Thanks,