Video issue on mobile only if stereo is off

Hi everybody, I’m working with UE 4.13.1 on a VR mobile project (Android and iOS). The app should work both VR and mono.

I have to play different 360 videos (latlong 2:1) with codec .h264 and .mp4 format. Everything works fine on PC (with preview render set to Android preview, i.e. ES2), but when I compile for Android (or launch from the editor) video render correctly only with stereo enabled on smartphone. If I turn off stereo, video stop render correctly.

Video with stereo ON

Video with stereo OFF

I think it’s not a memory problem, because I try with low quality video (960x480, very low bitrate) and the problem still happen. My Android supports video also in 4K and looks fine if I try with another app like GoPro VR, so I think it’s not a problem of video format/resolution.

To display the video, I use this shader on a sphere:
(note that material is Unlit, Fully Rough and has Use Full Precision)

I also try to remove CameraVector and LongLatToUV node and pin directly video texture into emissive parameter of the material, but problem still occurs.

So I sum up: a latlong 360 video render correctly on Android phone only when stereo is ON. When I turn off stereo, video stop render correctly (some videos goes entirely black, other videos look strange as in the image above).

Any ideas what happens here?

Thanks

Alessio

Hi Alessio,

This is a known issue with videos in mobile VR currently. Ticket references GearVR but it also occurs with GoogleVR as well.

Unfortunately, there isn’t a timeframe for when this will be fixed, but as a workaround, you can try this to see if it resolves your issue for the time being:

“Create a UMG widget and add a tiny border in the upper left corner. Set the brush color alpha to 0.01 so it isn’t visible. This will make sure it renders something last. This cleared up the problem in our testing.”

-Tim

Hi Tim,

thanks for help. I’ll try your suggestion.