Download

VERY unstable

4.6.1 on win7 64bit.
It’s very unstable and crashes very frequently. I spent more than 60 hours developing a prototype and suddenly the editor crashed and it refuses to open my maps. I tried everything including deleting loads of files and delete then re-install the editor but nothing worked. Finally I realized that the editor is taking more than 18GB of RAM out of my 24. When I gave up I reformatted my PC and installed a fresh win7 64bit then updated it to the latest updates and installed only visual studio express then Unreal. Guess what, It crashes AGAIN!!
I have submitted loads of crash reports please find a solution. The last thing any game designer wants is to lose so many hours of work.

Raed

1 Like

Hi there,

Sorry to hear your having problems with the engine, but I have a few things you can try to get it back up and running.

Have you tried using the backup autosaves from your project folder? They can be found in the ProjectName\Saved\Autosaves\Game\Maps folder, try opening the editor and loading an earlier one to see if it is a problem with the latest save file.

That is alarming to say the least… Is this when the editor is idle or while building the lighting? It is normal for building the lighting to take up quite a few gigabytes if you have a larger map, but when the editor is idle I have never seen mine go above 3gb.

If you aren’t able to load the editor, make sure you download and install the DirectX 2010 redistributable package as it is required (and not automatically downloaded by windows update).

If none of this helps, please create a post about this issue to the Bug Reports / Crashes section of AnswerHub along with the crash logs so Epic staff can investigate further for you.

Thanks, and let us know if any of that helps!

I had very much crashes also, and i figured out smth. If you have wrong name or wrong class name in your configs, which doesnt exist anymore or was renamed, then UE4 will crash when you open your project.

To fix this problem you need to manually change configs with proper names.

  1. Rename carefully.
  2. Use backups/perforce.

UE4 has very big problems with renaming. And then it doesnt show you warning message, it crashes instead.

I tried but no luck

I know! that’s why I took it more serious than just a crash which happens with many other software. By the way, It took 18GB while idle on a simple example map. It wasn’t even my map because I couldn’t open it at all.

I think directX comes with my graphic card. I used UE4 for few months without having to download directX

Thank you. Now I started my project all over again! If it happens again I will report!

Agree, I started to have the problem when I was trying to rename “door” to “door1”. After that even trying to manually rename it back to “door” didn’t help. I noticed that it keeps recreating and extra asset “door1” everytime it crashes and when I start the editor again I find both “door” and “door1” and none of them is accessible.

So when you open the map it crashes the engine? -> post your log file so that we can see what is causing the crash :slight_smile:

Also make sure to test it with the 4.7 preview (probably you can get back your content)

yes, as soon as I open it it crashes. sometimes it gives me couple of minutes of freezing the system. I tried 4.7 as well but no luck. where do I find the log file?

Go to your project folder - saved - logs - the most recent file :slight_smile:

Indeed, you certainly shouldn’t be having such issues with a stable version of the engine. That’s for sure. Even more so with those system specifications - I’m able to run a stable release on a low end Mac with minimal crashing, for instance (not my main system, obviously!).

So clearly there’s something wrong here. Do post up your crash logs, as aforementioned.

I changed the extinsion to .txt because the forums here didn’t allow .log
by the way I have loads of Dump-xxxxxxx.dmp files when the crash was happening and no log files at all.

Wow it tries to allocate about 50GB of memory O_O.

Could you delete the file: ComputeFilterWidth.uasset? The engine complains about it not having the proper engine version, might be the cause.

Is it suppose to be in the project folder? I can’t find any file with that name!!

Found it in the GitHub folder. Delete it anyway?

Should be here :slight_smile:


LogLinker:Warning: Asset '../../../**Engine/Content/Functions/Engine_MaterialFunctions03/Procedurals/ComputeFilterWidth.uasset**' has been saved with empty engine version. The asset will be loaded but may be incompatible.

But backup the file before you delete it :wink:

I just moved it to the desktop and renamed it. What’s next?

tried to open the project and the editor immediately crashed with this msg:

MachineId: DDDBD77C451304E47801A4855B9F0DB5
EpicAccountId:

We apologize for the inconvenience.
Please send this crash report to help improve our software.

the second attempt gave me a longer crash report

MachineId: DDDBD77C451304E47801A4855B9F0DB5
EpicAccountId:

Unknown exception - code 00000001 (first/second chance not available)

Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 54]
Ran out of memory allocating 53994222768 bytes with alignment 0

KERNELBASE + 37901 bytes
UE4Editor_Core + 3092349 bytes
UE4Editor_Core + 1597391 bytes
UE4Editor_Core + 697037 bytes
UE4Editor_Core + 723679 bytes
UE4Editor_Core + 2015663 bytes
UE4Editor_Core + 1885243 bytes
UE4Editor_Core + 2225428 bytes
UE4Editor_CoreUObject + 870426 bytes
UE4Editor_UnrealEd + 2797070 bytes
UE4Editor_UnrealEd + 2763775 bytes
UE4Editor_UnrealEd + 2700861 bytes
UE4Editor_UnrealEd + 2612749 bytes
UE4Editor_UnrealEd + 6316416 bytes
UE4Editor_UnrealEd + 3168772 bytes
UE4Editor_UnrealEd + 3167944 bytes
UE4Editor_UnrealEd + 6555369 bytes
UE4Editor_UnrealEd + 6310846 bytes
UE4Editor!GuardedMain() + 285 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:123]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Hi Raed Abbas,

Can you post to the answerhub at http://answers.unrealengine.com so we can better assist you? In your answerhub post. Please post your specific error, steps to reproduce this crash, your dxdiag, and the most recent .dmp and log files located in your saved\logs\ folder (as mentioned above). Thank you!

yeah? Leave it there until it dies or I give up? don’t bother Adam. I will give it a new go and see if it’s going to do the same thing again. If it does will have to unsub unfortunately. I love the system but I left CryEngine, after more than a year, because of the same reason, crashes on simple prototype game.

Mostly you get a really fast answer but atm you have to keep in mind that: :wink:

"Holiday Notice
In observance of the holiday season, most of Epic Games will be on vacation from December 22 until January 5th. Some support will still be available during this time. We thank you for your understanding regarding any delays that may occur, and wish everyone the very best during this holiday season."

When you could send us the map/project we can probably help you faster/better.

I guarantee you it wont die and will be investigated, just like every other crash/bug report posted on the site. I was planning on following its progress personally due to an issue I ran into yesterday.

I had nearly the same issue after adding in assets I downloaded from the Community Content forum, I launched the engine and it started eating up ram at an alarming rate (1gb ram every 5 seconds) until it eventually ran out of memory and crashed. I have a feeling it was caused by assets that were created in a different version of the editor, but I need to confirm that with the creator of the assets first (these were just a couple of materials and textures).

If you did something similar to that, I would find the assets and remove them from the content folder, then try launching the engine again. This fixed my issue but once I get more info I will be posting it on AnswerHub for Epic to investigate.