Download

Very low resolution of Viewport on Geforce 1070

Hi,

we are trying to develop a VR experience, in which we want to have a Spectator view of the person working in VR. We use for that a SceneCapture2D component which records the scene and streams it onto a texture which in turn is sent to the Spectator Screen.

However, whenever we show this on a PC, we get a very low resolution output from Unreal Engine.

The VR experience itself is OK in quality, but the Viewport just is too low resolution, which results in massive aliasing problems, and just an awful experience.

We have all the engine settings set to Epic, we have set r.ScreenPercentage = 100, r.PostProcessAAQuality = 6. We are running on a GTX 1070, with max quality settings for the project.

Here you have three screenshots:

1/ The screenshot of the experience as it is shown on the GTX 1070, on its monitor, as a SceneCapture2D output.
2/ The experience in editor on a GTX 770, on Epic.
3/ The experience run in editor on a GTX 770, on Epic.

anti-aliasing-03.jpg

How can we set a higher resolution for the SceneCapture2D?

Any ideas which setting in Geforce might be making my life difficult? :slight_smile:

I also set the texture for the SceneCapture2D to 2048 x 2048, but is still is very bad in aliasing…

Hi, how are you displaying the spectator view? Are you using the new Spectator Screen or a different way?

I am using this:

ScreenCapture.PNG

The documentation isn’t completely clear on how to use this, but I assume it is the correct way.

1/ Set Spectator Screen Mode to Texture
2/ Set Spectator Screen Texture to a RenderTarget
3/ I have set the RenderTarget resolution to 2048 x 2048
4/ I use a ScenCapture2D to fill the RenderTarget, projection type set at Perspective - 90deg

Hope this helps!

Can you try with this console command

r.setres 1920x1080f

Thx, that indeed is the resolution we have. I tried setting it to higher, which basically only shows part of the picture as it is too big for the screen. Making it lower res shows a small picture.

Also note that this problem is greatly aggreviated because we use a slow moving camera rig. If we make it move faster, the result is more acceptable, but naturally the initial aliasing issue remains…

I wonder how Unreal did this with the VR Spectator Youtube movie:https://youtube.com/watch?v=KHqXef1VK9o
There is no aliasing whatsoever…