Download

Very low FPS

I’m quite new to unreal but I’ve downloaded ue5 and even an empty level with just a player start is only giving me around 20 FPS, in ue4 a simple small level I get 120fps, using ue5 I can see my gpu is at 100% via task manager. Is this a bug or just not a good enough gpu? I’ve got a rx 570

Luman defaults to on and runs in software mode if you don’t have RTX.

So would I need to upgrade gpu or cpu? I tried turning off lumen and it made little difference

I also have an RX 570. And I also get very low FPS.
In a test scene in UE4 with high-poly stones from Quixel, I have 160 FPS.
In UE5, if I turn off the new features of Nanite (for static mesh) and Virtual Shadow Maps, I have 94 FPS.
If I turn on Nanite and don’t turn on Virtual Shadow Maps, I have 110 fps.
If I turn on Nanite and turn on Virtual Shadow Maps I have 35 fps.
Lumen was always off.

1 Like

Look this, and also look the fps counter: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

1 Like

I also get 120 FPS in a UE4 project and far less FPS (Around 45) in a UE5 project

You can also turn off the new project setting Temporal Super Resolution to improve performance.

r.nanite 0 in the console can give you a tiny performance increase if the scene does not have any Nanite meshes.

1 Like

Interesting. If I do r.nanite 0 fps increases from 110 to 260. But in UE4 the fps is higher.

I haven’t seen much difference between UE4 and UE5 performance wise. I am using a 3900X and 3090 RTX. Lumen and Nanite both on. The Ancient demo PIE runs a little low FPS, that is to be expected I guess with their recommended settings.

1 Like

With an RTX 2080 and i7-9700K the difference is huge between UE4 and UE5 with default settings: 250 vs 75 fps.

1 Like

I had some big luck yesterday and won a rtx 3060, when it arrives and I install it, I will post back with the difference the new gpu made.

1 Like

Awesome, rarely do I hear people actually winning awesome gear.

1 Like

Yo that’s badass. Congrats

1 Like

r.nanite 0 gave me pretty massive performance gains. I don’t think I was using Nanite so I’m not sure why It did.

Ok so my 3060 arrived and I just installed it, I’m now seeing around 45 FPS which is still low but probably being bottlenecked from motherboard and cpu too, it’s still double what I did have though

I have a i9-9900K (@5ghz) with an RTX 3090 and the Collab Viewer base project runs around 60-70 fps. Wtf is that all about?

Anyone figure out why disabling Nanite gives a boost? isn’t it supposed to be the opposite?

1 Like

In post 10 of the initial post Lumen GI and Reflections feedback thread - Development Discussion / Unreal Engine 5 Early Access - Unreal Engine Forums the instruction was given

Lumen’s use of ray-traced direct lighting is tied to the use of ray-traced shadows in the scene. You can decouple this by setting the following CVar:
r.Lumen.DirectLighting.HardwareRayTracing 0

However, you might opt to work without ray-traced shadows, since virtual shadow maps are the preferred method to use with Nanite assets.

I’ve tried all these methods, i’m getting 24fps in UE5 and 140fps in UE4.

Ryzen 9 3950X 16-core, 64gb RAM, SSD, (Purposely running on a GTX 1060 OC 6gb)

It is very strange, I actually want to use Nanite and Lumen, but if disabling them, is such a great solution, I think I’ll stay with dynamic lights and LOD’s for a while, sadly