Very Low FPS Issue (4.5, 4.5.1, 4.6-Preview)

Branch: 4.5, 4.5.1, 4.6-Preview (Source)

Build Version: 4.5.0-2316912+++depot+UE4-Releases+4.5

Detailed description of the issue: Opening a 4.4 project in 4.5 (either by converting or ignoring the differences) will result in 4.5 having massive FPS loss, no matter where you look. Best example for this is the Landscape demo, where my FPS would only drop when looking at water(ice surface) in 4.4, but be constantly low in 4.5.
This also happens with my test projects for my Random.Distribution plugin, which used to be running at just about 40 fps in 4.4 and barely get 13 fps in 4.5 now.
Update: This still happens in 4.6 when upgrading through 4.4 to 4.5 and then to 4.6, if your team did that. The solution seems to be to add and remove a node to all materials.

Screenshots / Videos: Not sure how to record UE4, all i get is a blank video with audio.

Repo Steps:

  • Open project in 4.4, measure FPS using the editor.
  • Convert same project to 4.5, measure FPS again.
  • There’ll be a huge difference between both FPS counts, no matter the settings/scalability settings.

System Specs:

  • CPU: AMD FX-6100
  • RAM: 16.0GB DC DDR3 1333Mhz (9-9-9-24)
  • GPU1: NVIDIA GeForce GTX 550 Ti
  • GPU2: ATI Radeon HD5770 (CuCore)
  • OS: Windows 8.1 Pro 64-bit

Attachments: None

Did some more testing on my own Project:

  • Behaviour doesn’t happen as extreme when building from source, the build in the launcher might not have any optimization applied to it.
  • However, the framerate drops significantly near masses of instances of meshes. This makes placing grass near impossible, as it is only supposed to render nearby.

I also have this issue. Used to get 60-90fps based on what was happening on screen in my game, now I get 30-40fps

I’m also having the same issue, though I’m using the final 4.5 version. Yes mesh instancing could be the problem. I have a top down map where I’ve added a lot of grid meshes (around 1600) dynamically along the map. My fps has dropped from around 36 fps to a non-playable 5fps. But I’m guessing there might be some editor default settings changes in the lighting/shadows as well.

I don’t know what was done, but the huge framerate loss is gone when building from source. Not sure about the launcher build yet, still downloading that one. (;_; incremental downloads would be nice…)

Edit: Nevermind, I forgot that I reduced texture quality in that project.

Hello ,

I was able to reproduce this issue on my end and I have submitted a report to the developers (Jira: UE-4471). Thank you for the information that was provided on this issue. I will update you with any pertinent information as it becomes available.

Same behavior with my game as, drop from 80-90 to 10-15 fps

Any news on this? Currently I can’t upgrade to 4.5 due to the massive performance decrease.


Hello AdrianLazar,

This issue has been recently resolved internally. If you are still experiencing this issue after the next update please feel free to let us know and we will be happy to assist you further.

Make it great day

According to some of my team members, this issue is still a thing. Apparently it only happens after conversion of a project, and is fixed by adding and removing a node to materials. Minor inconvenience.

Same here, I still had the issue here a couple of days back.Tried both 4.5.1 as well as 4.6 preview. Could be due to the conversion as you said. I have since moved on to reducing the number of grid meshes from around 1.5k to dynamically spawning 9 local grid meshes. That brought up the frame rates by around 60-70. v4.4 ran the level with 1.5k meshes around 35 fps. So it could be some memory/draw call issue with static meshes as well.

Hello ,

I was unable to reproduce a frame drop difference on my end. However, if you could try booting up the effects cave in 4.5 and then upgrade a copy of it to 4.6 and compare the two it would help determine if this problem is project specific. After running the test please contact me back with the results and we can go from there.

Make it a great day

Hey Triplett,

it seems to only be affecting projects that go through the following update process: 4.4 → 4.5.1 → 4.6. Going 4.4 to 4.6 and 4.5 to 4.6 results in the original performance on all machines (except weaker ones). The loss in performance is usually about 80-90%, causing machines that used to run at 120 fps to go down to 20-30 fps.

The reported fix is to add and remove a node to all materials. For us that isn’t so hard to do, we only have 4 anyway (instancing wooo), but for other projects that might be a lot harder. And who knows if that bug will not reappear when shipping to an end-user with completely different hardware.

Keep in mind that I currently do not have access to 4.6 and this is what the affected team members told me. We’ll be waiting with upgrading to 4.6 until it hits release.

Yours sincerely
Michael ‘’ Dirks

Hello ,

I have as you suggested upgraded a project from 4.4 to 4.5.1 to 4.6 and I am still not seeing more than a 1-2 frames worth of difference with them running side by side. However, I did notice that if you have a second monitor and you click over to that second monitor the newer versions of the engine will drop their FPS while the window does not have focus. 4.4 does not appear to have this feature. Other than this, I cannot reproduce the issue. Are there any other known factors that could be contributing to the problem? If so please let me know and I will be happy to investigate further.

Hey Triplett,

we know about that feature, it’s very helpful to us. I don’t know what could be causing the problem, all the team members machines are near identical (with minor software differences):

OS: Windows 8.1 Pro 64bit (Automatically updated)
CPU: AMD FX-6100 or AMD-FX8100
GPU1: NVidia GeForce 780 Ti or NVidia GeForce 980 (GDDR5)
GPU2: AMD ATI Radeon R7 260X (GDDR5)
(Two Monitors)
RAM: 16 GB 1333 DDR3 or 32GB 1866 DDR3
HDD: Western Digital VelociRaptor 1TB + Western Digital VelociRaptor 1TB (RAID0 Striped)

The dual-GPU setup is to test how it looks on either GPU manufacturer by just changing where the game will be in fullscreen. I don’t know if this is causing the issue (Unity & CryEngine handle this just fine).

Yours sincerely
Michael ‘’ Dirks

Hi Rudy,
Watching with interest this thread. I don’t have time now but next week I’ll try to upgrade from 4.4.3 to 4.6 preview and see what happens.
And thanks for all the other fix suggestion like the one with the materials node - I’ll try it out though I have a lot of materials :frowning:

The issue was fixed in 4.6 Release. Both source and binary version no longer require material adjustment to make it work, even when going through 4.5.1. Actual cause of the issue is still unknown to me, but it’s great that it works now.