Very broken rendering

Hi, I opened my project today and found that despite no changes being made, it was completely broken.

What it looks like in the viewport:

(roughly) what it should look like:

The situation:

  • Mesh faces either flicker or do not
    draw at all, with some faces drawing
    in front of others incorrectly.

  • Some meshes are entirely invisible

  • The sky sphere renders correctly

  • The number of faces that get rendered are seemingly different each
    time I open the project (sometimes I
    get nothing and other times an image
    like the first shown)

  • Meshes, materials etc are fine when I open the asset with seemingly
    no issues.

  • The editor icons that it draws to show decals, lights etc all no longer
    rotate towards the camera for some
    reason and are just flat textures

  • Nothing can be moved by dragging the axis arrows that appear upon selecting an object. All objects are stuck in position.

  • 2D wireframe views show that all meshes are present and look normal.

  • Other projects work normally

What I have tried:

  • Using Vulkan instead of DX12
  • Restarting PC
  • Fixing redirectors
  • Reloading materials

Any help would be appreciated. This is driving me insane.

Scratch that, I just found that this issue is caused by setting NearClipPlane to 0. I’ll leave this here for anyone that may encounter this issue.

1 Like

I think that Epic Games should limit this value to 0.01, because I have spent a lot of time trying to fix it, recompiling all shaders, … Setting the value to 0 is initially working fine, then the problem doesn’t seem coming from this. The final build also reflects the same bug. It can be disastrous, if the build that was working locally is shipped like this.

I also tried to update my Nvidia display adapter drivers…

DasCyanic, thank you very much for sharing!

This still seems to be an issue in 5.3. Very hard to find the cause, as it only breaks after restart of Engine. Please fix with a limit!