vertex paint doesn't work

Could someone point me in the direction of a tutorial on how to vertex paint?, I’ve watched about 15 so far and none of them work for me.

I have 2 textures both leading into a lerp, vertex color plugged into alpha (no bump etc as that just makes it even more pointless), I get it possible needs vertices in order to paint, but how do you change that.

All I want to do is add a moss layer onto concrete, I may as well just make a boring generic texture in photoshop if its really this hard.

Fixed, how no idea how however

If you want to find out still, show me the material setup and I can probably tell you whats going on :slight_smile:

I thought it would work the way the source engine works where you could have a bsp with more vertices. However UE4 doesn’t support that and since reading up it looks like static meshes are better performance wise anyway.

Some questions I do have however are,

  1. should a static mesh (that is representing a floor be a plane or box), I doubt I will convert a bsp as it appears that you can’t increase the number of vertices anyway. Does Unreal ignore untextured surfaces when compiling/building the world. (you could place a no clip texture in source which would en-force this).
  2. How much of an impact does vertex painting have on performance if you are looking at large worlds. I would like the textures to be varied in there look so as not to have that tiled look from the air.

I haven’t played with complex textures in Unreal before as most of my experience was high polygon modelling in Zbrush (i.e just do whatever its being rendered)

Yep, I am having this issue. I am going with the simplest setup, texture sample, texture sample lerp, alpha vertex color. Tried painting my model nothing, tried painting default cube nothing, used a highly tesselated sphere converted to static mesh nothing. It refuses to work. I click see Vertex RGB it disappears on me, any of those causes it to disappear instead of showing the color channel. It flat out refuses to work. On the sphere, I have texture mode trying to do something but it is not doing exactly anything specific. I think it applies the texture given and erases it… I bet it is due to me having it set to a textile density that it does not like as in it is larger than it should be for the UV island bit. Still, the texture does not apply with colors either way.

I figured it out, the guy who made that tutorial failed to mention that your mesh had to have a specific number of verts for it too work or it wouldn’t paint anything