Vertex animation FLIP from Houdini weird artefacts

Hello, all you Unreal Masterminds :slight_smile:

I’m fairly new to Unreal (so far, I was a Houdini TD) and I’m trying to export FLIP sim from houdini to UE 4.

I followed all steps mentioned in the GDC 2017 presentation (link: and finally I managed the sim to look sort of as it should (shapewise). But there are some weird artefacts (please see the gif), that look like some kind of a problem with normals…

UE always displays a message when I import the meshes:
“No smoothing group information was found in this FBX scene. Please make sure to enable the ‘Export Smoothing Groups’ option in the FBX Exporter plug-in before exporting the file. Even for tools that don’t support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.”

But in Houdini I couldn’t find this option in the FBX exporter anywhere. I tried exporting it -with normals on vertices, -on points, -without normals, -as polysoup and nothing worked…
In UE, I have properly set the number of frames, the bounding box MIN and MAX, I tried to turn ON and OFF the -use full precision uvs and -use high precision tangent basis options… Nothing solved it.

Is this Houdini export problem, or am I missing something in UE?

I’m using the GDC_2017 zip vertex map exporter, FBX 2016 and UE Version 4.17.2

I’ll be really grateful, if anyone helps me out with this one…

Also does anyone know, if it’s possible to control the vertex animation from within the game? If I can start it stopped and let the player to start/stop it somehow? If it’s possible, could you just point me in the right direction?

Thank you, bye!