Vehicles are completely broken by default

There has been a problem with the vehicle physics since Unreal Engine 4.14 was released. It causes vehicles (including the default vehicles, both basic and advanced) to float above the ground when driving off a ledge. It also does this on some of my spline generated roads as well.
I have no idea what causes it but if I had to guess, it would be that the vehicles no longer register properly that they are in mid air when they are above a spline road mesh? That’s a complete guess though. I’m no expert in C++ therefore I have no ability to properly diagnose what’s even happening here.

I made a video to show you what I’m talking about.

I also made a project so you can replicate the issue in house:

It’s been an issue for over a year. Please fix this.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


UPDATE 2: This is not answer for your question, my next (my latest) answer post is what you need. This post is for different (more generic) vehicle bug.

Fix for when your vehicles dont have collision (go through floor)

Im 95% sure, that you simply need to reduce wheel size (reduce them by a lot).

To do this:

  1. open the Wheel BP (you have either one of these or two of these - Front and Rear. It is where you set Wheel Radius, Steer Angle, and where you set which Tire config asset to use)

  2. When opened (it’s “Class Defaults only” type of BP), edit the (Wheel) “Shape Radius”. Currently you set it too high, in your case it is like 50-150 or so, set it to 1 (for testing purposes only, then you will change to your desired size). For testing purposes set the same size for both Front and Rear wheel Blueprints. Dont forget to hit Compile & Save in that BP editor window before testing again.

Keep in mind, that:

  • If you set it too high (more than wheel’s mesh size) - then car will “fly” like in your video.
  • If you set it too low (wheels will not go under floor) - never. Instead they will collide at mesh’s size, The only difference will be - is how wheel rides around obstacles.

Eventually you will want it to be, like 15-25 (for normalized measuring units and real-like mesh sizes).

By the way, wheels going into the floor (having no collision) - is completely different issue, which is answered in that forum post of my nearby answer message (it is not for you, you only need to decrease shape radius, it will be enough).

Unreal Engine is simply still to weak for Car Physics. There is no defined Way how it would actually work. It just “looks” like working in terms of configuration options etc. But what do those features help if very simple things are 99% failing and behaving not as expected?