Download

Vehicle won´t rolling further downhill after tires stands still

Hi together,

i´ve used the “Vehicle Advanced”-Template and try to let the Vehicles roll downhill without using Throttle-Input. Just rolling, but if the tires stands completly still the Vehicle don´t roll further.
Which things have to changed that the car rolls?

Thanks in advance

Nobody knows a solution? Maybe it’s just something small and simple

https://forums.unrealengine.com/core/image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAUCAQAAAAngNWGAAAA/0lEQVR4AYXNMSiEcRyA4cfmGHQbCZIipkuxnJgMStlMNmeyD2dwmc8+sZgxYJd9ErIZFHUyYYD7fkr6l4/rnvmtl7+KitrqV/fq2Y5eLY3Z9S48eRLe7BmVZ9qhTLhQ0algzZWQOVKSsCF8OjAnwbxDTWFDUhPK/jMr1H6HE/IqRky2DyvCefuwItwZzodVoYRiLqMkVCXrwpJ9twZ+sgfDYEFYl8wIWxZ9uFf7zkallxlJh4YrLGsKjZRx7VGHhLqwgFUN45DGdb8MeXGpgB4ABZdeDcpZEY51A+hyLKz4S1W4MQWm3AibWtgWmk6dyISa1pSdyWTOlLXVp0+eL9D/ZPfBTNanAAAAAElFTkSuQmCC

Hi, you might wanna try setting the “Stop Treshold” in the wheeled vehicle movement component to 0 (by default it’s at 10, meaning if the vehicle is slower than 10cm per sec, than it will automatically brake).


[HR][/HR]
But even if you set it to 0 or negative, if the velocity of your vehicle is 0, then it will still automatically brake. To counteract this, when the velocity is 0 and based on slope, you could set a small throttle input, so that the vehicle won’t stop. But keep in mind that this would also mean that when the player wants to stand still on a slope, then he would have to use the handbrake.

Hi chrudimer,
i tried your solution and everything fired, but the car stands still. Is the BP not correct? What am i missing?

Thanks for your help

First thing I would try is checking whether or not this “Set Throttle Input” is actually executed (so doing a print or setting it to a high value like 1,0), seems to me you’ve already done that.

Since “Set Throttle Input” will override the last value, next I would check all other usages of “Set Throttle Input”. So you would have it set at least one other time, namely for the player input. And the axis events will fire on tick, so it may be that you override the value you’re setting here with 0 somewhere else.