Vehicle wheel collision problem


We have a problem with the vehicle system. We have checked all tutorials, videos and other relevant stuff that posted by either community or epic heroes, but couldn’t find a point about that.

We have imported our vehicle model to Unreal Engine 4, set all necessary settings with that. Model has 4 tire bones which are connected to root bone placed at 0,0,0, defined collisions as sphere for wheels, box for body temporarily. When we press forward button, force goes to wheels, not problem with that either.

But the weird point is, when we set wheel collisions in physics asset as “kinematic”, (body(root) stays at default), unreal does not recognize wheels’ collisions. Vehicle falls to ground within collision of the body’s constrains.

If we set all wheels as simulated, problems’d have been solved, but as predicted, vehicle does not move in that case. If we set wheels as kinematic, wheels go under the floor, unreal detects only body collision.

By the way, if we simulate the vehicle’s physics in physics asset tool, physics go crazy, but in level scene as controller, that physics madness is not happening.

Thanks for your help in advance.



Running the game: (Result)

Physics asset - root selected:

Physics asset 2 - tires selected:

Blueprint 1:

Blueprint 2:

Simulating on physics asset tool:
[link text][6]

Which version of the engine are you using? It isn’t necessary to set the wheels to Kinematic since 4.4 as far as i know. Leave them at Default and see how it goes.

We’re using 4.4.0 currently. But even though we set wheels as default, it inherits root’s characteristic as default or simulated, in short;

root = default, wheels = default => No Collision on wheels

root = simulated, wheels = default => Collision exist, but no force on wheels

root = any, wheels = kinematic => No Collision on wheels

root = simulated, wheels = simulated => Collision exist, but no force on wheels

Updated engine to 4.4.3, still no effect. Any ideas?

can you try the command pxvis collision. This should show you a debug drawing of the actual wheel simulation. Jacky is right, you should be able to leave the wheels to default. Is it possible your wheel class has problems? Is the wheel radius set correctly?

Hello Ori, thanks for your reply, I have attached pxvis collision and show collision debug results.

That’s quite weird actually, we couldn’t find out why pxvis collision seems rotated. Do you know how we can fix this?

Export car fbx from Vehicle Sample and look how wheels’ cordinate system is constructed.
In the skeleton viewport should be:
X - point forward
Y- Right
Z - Up

Also there’s a video about the situation.
link text

I suspect this is the issue, can you confirm BurakShamansoft?

Also, once you set the position of the parts as Pierdek described use an Xform modifier(if you are using Max) before you link the wheels to the body.

Thanks for your replies at first. Pierdek, if you have mentioned about joint rotation of wheels, we tried both positions and nothing has changed. Jacky we’re using maya as third party 3d soft, not max. It seems weird actually, as you know x-y-z coordinates of maya and unreal are quite different. At the beginning, we suffered export-import issues which are caused by axis difference, but designing in maya axis, exporting to unreal with “Select up-axis as z” option selected solved the problem. We applied the same solution to wheels also, but it didn’t seem okay. Also tried the change wheels axis to other options, nevertheless that has not solved it.

You can download the fbx file that we used on this link.


Ok, i got it working properly in Phat, but i passed it through Max > got rid of the bones and skin modifiers > reset Xform > and linked the wheel meshes to body mesh. I’ll let you know if it works as a vehicle BP too.

And it works perfectly. :slight_smile: Would you like me to send you the whole vehicle BP or do you want to solve this issue with Maya yourself?

I’d be grateful Jacky :slight_smile: But all of our designers are using maya and blender, if it is an issue that caused due to maya exporting system, it’d be painful for us in future. It’s weird to get such problem in maya, it’s a widely used program after all.

It cant be Maya related since many people including Epic artists are using Maya. It is something you are missing in your workflow but i dont know what since i have no Maya experience. Ask around in the forums if you cant get further help here.

Here’s the file: Dropbox - Error

Unzip > Copy the Meshes folder in Content folder > Paste it into your project’s content folder and everything should work as expected. The only extra you need to do is set wheel radius in wheel blueprints.

It works perfectly as you said Jacky, thanks, by the way, did you see any anormality in our model before you modify it on Max? I mean in joints, bone connections etc. Because we set all adjustments as you did in the file, but ours are still not working.

By the way can you send the fbx model that you modified and exported to unreal?

Okay, Jacky’s method has solved the issue, even in maya. As I understand, 3ds Max’s reset xform equals to Maya’s Reset transformations. After setting all bones properly, we reset transformations and that made the problem been resolved. Thank you Jacky! :slight_smile:

Glad you figured it out in Maya too! :slight_smile: Also keep in mind that you dont need to use bones if there is an equivalent of Link in Maya too. Just set the pivot of the body at 0,0,0, set the wheels’ pivots accordingly and then link the wheels to the body and export. Then select Import Rigid Mesh in import dialog window.

Jacky, hello again, do you still have the fbx file that you edited and exported to Unreal? We still have that kind of problems, if you can send, our designer will analyse it. We gonna have bats in the belfry :slight_smile: We are still crawling with similar issues.