Vehicle doesn't always spawn for multiplayer games in Vehicle template

If I launch a play session in the editor with 3 or more players in the Vehicle template Blueprint project, sometimes one of the vehicles fails to spawn, even though there are 3 player start instances in the map.

Steps to reproduce

  1. Launch UE4 editor
  2. Start a brand new Blueprint project from the “Vehicle” template.
  3. Set “Number of Players” to 3 in the “Play” dropdown menu.
  4. Click “Play” to start a session. (Might need to do this several times.)

Expected result

There are 3 game instances visible, and in each one, the camera is looking at a successfully spawned Vehicle (an instance of the Sedan blueprint).

Observed result

About 1 time in 3, the Sedan will fail to spawn in one of the game windows, and the camera is positioned at the world origin.


  • There’s an even simpler reproduction of the issue available - delete the single Sedan instance from the map, and also delete one of the player starts, so there are just 2 left. Then set the number of players to 2. Click play several times, and the bug will happen probably 50% of the time now.
  • Pretty sure this happens in version 4.13.2, also.
  • I tried to file this bug against version 4.14.1 (the latest 4.14 series release), but there is no such version in the dropdown version box, so I just had to go with the closest match, 4.14.

Hey njsand,

After some testing, I don’t believe that this is a bug necessarily, but I’d like you to try something:

Do me a favor and try disabling the Auto Connect to Server option under Advanced Settings, which you can access by clicking the dropdown arrow next to the Play button.

Once I did this, I didn’t see that behavior occurring anymore.

Thanks and let me know if that helps

Thanks for looking at this, Sean!

I disabled Auto Connect To Server as requested and gave it another shot. I tested it dozens of times, and didn’t see it happen again, so I can confirm the problem goes away in that case.

However, that doesn’t really help me at the moment. The reason being, if we disable that option, our game instances aren’t connecting to any server instance, correct? In other words, there is really no multiplayer game going on. If we look around (or drive around) in one of the game instances, we don’t see the other players - there is no shared world.

The point of my bug report is specifically that the multiplayer spawning doesn’t always work. I initially encountered this is in my own project, but tested the replication in the standard vehicle example, to make reproduction easier for anyone reading this. It seems to me in particular (just speculating here), that the engine is having trouble checking the player starts somehow, for the vehicles.

As a side note, for other project templates, such as the third person template, this problem does not happen at all. Multiplayer spawning works just fine, always, there. It must be something peculiar to the Sedan pawn or it’s construction that’s the issue.

I think I’ll be able to find a workaround by overriding my GameMode instance to choose spawn points based on tags, or some other technique. But, I still think this is a bug worth reporting, because the default and simple case of the vehicle template should work, IMHO.

I also tried the following for good measure.

  1. Disable Auto Connect to Server in the advanced settings.
  2. Hit Play (new editor window) with number of players set to 3
  3. In the console in window 1, do open VehicleExampleMap?listen to start a listen server.
  4. In the other two windows, do open to connect to the server
  5. Repeat step 4 several times.

After a couple of repeats, one of the clients will fail to spawn a Sedan vehicle.

After further investigation and discussion with other team members, it appears that the starter templates are not set up for multiplayer by default, which could explain why you’re seeing the issue that you’re currently running into.

I’ve attached my own test project that I use for multiplayer issues.If you go in and disable the Auto Connect to Server option in that project, it will spawn the character consistently, at least on my end. I’d recommend taking a look at the setup there and seeing if there is anything that you may be overlooking in your project that could be causing the pawn to fail to spawn.

Let me know if you have any more questions.


link text

If the vehicle starter template is not meant to support multiplayer, as per the steps in the “steps to reproduce” above, then I guess this is not a bug. I have to say this is kindof suprising behaviour to me though.

Thanks for attaching your test project, I’ll have a play around with that.

No worries, hopefully it’ll have something in it that could help.

Let me know if you have any further questions regarding this issue.

Have a great day