Vector Intrinsics Failed when Initializing

Hi, everyone.
I built 4.23.1 source code with Visual Studio 2019 16.3.6. It was successed, but the UE4Editor.exe triggered a breakpoint when it initializing.

There’s the output log of breakpoint:

[2019.10.24-05.44.19:856][  0]LogUnrealMathTest: FAILED: V.ToOrientationRotator() rotate
[2019.10.24-05.44.19:856][  0]LogUnrealMathTest: Bad(1.577350): (1.000000 -0.000000 -0.000000 0.000000) (0.577350 0.577350 0.577350 0.000000)
Fatal error: [File:D:/Unreal/Engine/Source/Runtime/Core/Private/Tests/Math/UnrealMathTest.cpp] [Line: 1525] 
VectorIntrinsics Failed.
UE4Editor.exe has triggered a breakpoint.

I checked the output log, I found all of the MathTest were failed and the GPassing was false.
I tried to clean the solution and rebuild, but it’s still doesn’t work.
I can’t figure out what’s going on, I’m very appreciate that someone can tell me how to deal with this breakpoint.

I built with Win 10 SDK 18362.0.
Have I change it to 17763 and rebuild?

I also experienced this.

See Visual Studio Feedback

MSVC 14.23 causes this issue, and still maked as Under Investigation.

So, possible workaround is just rolling back to MSVC 14.22.

You can specify target toolchain version in Engine/Saved/UnrealBuildTool/BuildConfiguration.xml.

Mine is:

<?xml version="1.0" encoding="utf-8" ?>
<Configuration xmlns="">

See Build Configuration | Unreal Engine Documentation for more details.

Thanks a lot for your help~~
The code was helpful. I rolled back to MSVC 14.22 and modified the file like yours, then rebuilt the whole engine.
Although it tooks me about 2 hours, it finally worked !!

Just a note for you: this issue has fixed in Visual Studio 16.3.9(MSVC 14.23.28105) and Visual Studio 16.4 Preview 5