Variable don't view in blueprint

Would you mind posting the code you used? Maybe you have a typo or something (:

Hello, for five days I have a problem whith the variable and blueprint.

I have create variable in my code but the variable dont declared in blueprint?
I have try create variable for other item but it is the same thing.

I have remarque that during the generation that the code dont updating.

Thank you for answer.

// Copyright 1998-2014 Epic Games, Inc. All Rights Reserved.

#pragma once

#include "AzordianChampWeapon_Projectile.generated.h"

struct FProjectileWeaponData

	/** projectile class */
	UPROPERTY(EditDefaultsOnly, Category=Projectile)
	TSubclassOf<class AAzordianChampProjectile> ProjectileClass;

	/** life time */
	UPROPERTY(EditDefaultsOnly, Category=Projectile)
	float ProjectileLife;

	/** damage at impact point */
	UPROPERTY(EditDefaultsOnly, Category=WeaponStat)
	int32 ExplosionDamage;

	UPROPERTY(EditDefaultsOnly, Category = WeaponStat)
	int32 test;  /*     <============================ My variable create*/

	/** radius of damage */
	UPROPERTY(EditDefaultsOnly, Category=WeaponStat)
	float ExplosionRadius;

	/** type of damage */
	UPROPERTY(EditDefaultsOnly, Category=WeaponStat)
	TSubclassOf<UDamageType> DamageType;

	/** defaults */
		ProjectileClass = NULL;
		ProjectileLife = 10.0f;
		ExplosionDamage = 100;
		ExplosionRadius = 300.0f;
		test = 100; /*     <============================ My variable create*/
		DamageType = UDamageType::StaticClass();

// A weapon that fires a visible projectile
class AAzordianChampWeapon_Projectile : public AAzordianChampWeapon

	/** apply config on projectile */
	void ApplyWeaponConfig(FProjectileWeaponData& Data);


	virtual EAmmoType GetAmmoType() const override
		return EAmmoType::ERocket;

	/** weapon config */
	UPROPERTY(EditDefaultsOnly, Category=Config)
	FProjectileWeaponData ProjectileConfig;

	// Weapon usage

	/** [local] weapon specific fire implementation */
	virtual void FireWeapon() override;

	/** spawn projectile on server */
	UFUNCTION(reliable, server, WithValidation)
	void ServerFireProjectile(FVector Origin, FVector_NetQuantizeNormal ShootDir);

My variable create is “test”

Hm, so only the “Test” - Variable doesn’t show up in your Blueprint? The others like “ExplosionDamage” work?

Thank you for your assistance.

The others vaiable display is blueprint.

No the variable test dont appear

If you create a new blueprint from the changed and recompiled class, does the variable “test” appear?

Ehm, would you mind trying to write “Test” and not “test”. So using a capital letter.

And please, use the “reply” or “add comment” button instead of posting an answer every time.

I dont have the buttom reply or add comment.

Excuse me.

I using a capital letter and it is the same resultate

Isn’t there a reply button when you move over one of my comments with your mouse?

At topic: Hm, then i can only guess. I don’t see any difference to your other variables. The only thing that is different is the way you declared the category.

Try removing the spaces and write the Category like you did in the other UPROPERTYs.

Not “Category = WeaponStat” but “Category=WeaponStat”.

I remarque a problem during the generate.
I create new class and generate but my class dont appear and nothing appear in the out of generation.

Problem is resolut change generate “debug game” ===> “Developper game”

Thank you for you assistance. Goodbye

Ok, that is something i havent thought about. Would you like to mark your question as solved by clicking the check mark at the left side of this answer? (: So everyone knows its solved already.