Valve Index - Action and Axis mappings aren't working.

Hey everyone,

We are using the Valve Index for an ArchVis project and are having issues changing some of the keybind in project settings. So far we have the VR’s teleport on the Index’s trackpad but wanted to change it to the Thumbstick. We are using the default VR template, however no matter what keybind we change for the teleport event, it doesn’t seem to update the .ini file or it won’t actually register the action input.

323594-xl-actionmappings.png

EDIT We have two projects in VR. One of them works fine with the Index controllers. The other does not work at all. I noticed “steamvr_ue_editor_app” was pointing to the wrong path. I tried to fixed that manually but with no luck.

I have also tried the Steam VR plugin solutions as pictured below but nothing will seem to resolve the issue. When we go to the project in the Steam VR dashboard (controllers section), it constantly says

324464-steamvrplugin.png

I don’t know anything about this VR controller, but it seems like you’re talking about switching from Axis events to Action events. You have to put them in a separate section.

Also, have you actually looked in the ini file to check? Is it updating?

It’s set to the trackpads click feature, which works fine, but the client wants it on a thumstick up. The actual event is an action event but it doesn’t register the change but the change is there in the .ini file.

I can’t access raw inputs for VR (especially index) as it’s not an Xinput (i think thats what it is called).

This has something to do with a problem I encountered and resolved recently found here: https://answers.unrealengine.com/questions/993568/view.html

can you find the link again? that one is no longer available plz