Download

UVs outside of 0-1 range & rectangular texture

Hi guys, I came back to one of my projects I left a while back, and I was cleaning up some modular pieces I had. Problem was, that as I had mirrored pieces stuck together, I got a nasty texture border edge seams running along all of them :frowning: Anyway, as I could see the problem in Maya once I turned on the advanced viewport, I connected the mirrored UV shells and extended my modular textures to be 2048x4096 instead of 2048x2048. I set the UV coverage to be 1x2 and it fixed the problem, within Maya that is.

I can’t match up the UVs and the texture within UE and it’s annoying me to no end! Coordinate tiling is not what I need, but I can’t find a coverage thing anywhere.

5e79e703394b512b629c4a4817d93d84751e53e9.jpeg

Before trying to fix the border seams, my UVs for the diffuse where across the 0-1 space and stretched across the neighbouring LHS space; the mirroring UV shells were overlapping, and creating the seam. So I merged the shells together so they went to the space above 0-1. Anyway can I accomodate all of this into UE without remapping everything AGAIN?

For textures you aren’t restricted to the 0-1 UV space, you can extend far beyond that, the only concern is a lack of precision once it gets large enough. Also, if you’re using 2048 textures, that is not necessary, your texture is very simple so it shouldn’t be large at all, if it’s just two colors you can make a very small texture with a swatch for each color and then map them very easy for wherever each color needs to go.

So if I’m not restricted, why does UE4 seem to only be utilising the 0-1 space? The texture itself has more detail than two colours, and I prefer working in big numbers before scaling down.

Still have the coverage problem, any other ideas guys?

I don’t understand the coverage thing. Is it some maya specific thing?

This is from the Maya docs:

So as my V is set to 2, it looks at the space above 0-1 as well. Just how the heck do I do this in UE as well?

Are you sure that the coverage setting is supported when exporting as .FBX from maya?

Don’t know if you can find this useful. I use Material ID’s on surfaces. A lot more efficient and less of a hassle than messing with UV space beyond 0-1. It’s awesome if you want to use a lot of 2K textures on huge model piece for example.

This should answer that, Look at the links at the bottom.

HTH

Literally just tried that - I thought maybe if I mirror my texture into a second mat ID, that would work. It SEEMED to work, from afar. Zoom in and you still have that bloody seam! It is driving me insane, it’s just a darn padding error, but how do I get rid of it?? I have no plans on hiding the midway section of my walls, this is just becoming ridiculous.

As I gather that talks about UV wrapping, which doesn’t really help out in this case? Anyway I did try mirror wrapping, didn’t fix anything :frowning:

can you post a screenshot from inside UE4Editor with the seam issue. please and thank you.

I think the coverage setting you’re talking about in Maya is just the tiling setting, so a value of 2 tiles the texture twice in that direction, the UV doesn’t extend beyond the 1x1 space, it just makes the texture fit twice in that space.

Enable pixelsnapping in Maya while layouting your uvs…this will make sure u have no visible seam. There’s no other magic involved…also make sure u import the uvs from Maya and not recalculate them via ue4 on import.