Download

[UV] Render problem on the border of the UV seams

Hello everyone,

I’ve made this helmet and double-checked all the maps, but I couldn’t solve this. The borders are where the UV islands are separated. Is it a normal map issue?

I have pretty much the same problem. I posted this question on the Modo forums but got no responses.

Left is the in-engine asset
Middle is the normal map viewed on the model in Modo.
Right is the UV map.

If you look at the normal map, you can see that there are sudden change in the normal value around the circumference of the rings, but it should be blended smoothly. The lighting problems in UE4 aren’t visible in Modo, but it’s clear that they fall on the UV seems in UE4.

The low poly mesh is just a quadball subidivded several times. As the object is completely round and can be viewed from any angle, I don’t really have anywhere to hide the seams.

I did set the entire thing to one smoothing group [Modo >> Vertex Map >> Set Vertex Normals].

So how do we prevent the sudden jump in normal values across UV seams?

Make sure when you import the normal map into UE4 that it is set to use Normal Map compression, otherwise it will not render correctly.

Thanks for the tip darthviper. I did need to make that change, but it did not solve the problem.

I’ve discovered a little more about the issue. A pixel with the same normal as the polygon it falls on should have an RGB value of [128, 128, 255]. However, modo is producing maps with [188, 188, 255]. If I change all the values through Photoshop, the seems go away-- However, I’m also losing any information about the roundness of the faces (ie. the curve on each face of the quadball is presented with a consistent, flat normal, instead of the curve that I want).

Any thoughts? I’ll also post my findings on the Modo forum.

Sounds like it might be a gamma/linear/RGB issue.

Thanks Zac, that was it! I had to set the color space to ‘Linear’ for my images.

8cc05fd4f081e5dcc13094853d6b75471ebce2ca.png

Here it is fixed in UE4, with the new UV map (notice the color difference). I also included my settings window (in Modo), for anybody who comes along in the future with the same problem.