Download

UV mapping import problem

i made a mesh in Blender, and i checked it, and i think it’s clean. i say think cause i’m an advanced starter, and i may have missed something. but i checked duplicates, normals orientation, and i even triangulated to avoid large non uniform normals (not sure this has a real effect, but i did it :D). so i imported the mesh which even if it has lot of hollows isn’t that complex (only 4300 faces). the mesh imports without errors. and i’m pretty sure it’s textured, as it doesn’t show up the default race grid. but the UV is not what i have in Blender, at all. what drives me nut, it’s that if i do exactly the same thing with a simple cube, the texturing is perfect. i used project from view in blender to get an uniform UV mapping, but it messes up also with smart UV project. So i’m wondering what i did wrong

blender

UE

as you can see there’s no grid, so it’s very likely textured, but not like it should

Hi!

I don’t really understand your problem! :S The mesh looks perfect to me…
Could you show the UV channel(s?) in blender and the UVs that arrive differently in Unreal please?
…or if it’s texture related (your texture is not showing up on the model?) : are you sure you’re using the correct UV channel in the material node in your texture setup?

Hi Makigirl, yeah the mesh looks great. but the UV mapping is wrong. the UV mapping looks a bit messy. cause i UV mapped using angle (project from view) to get a clean looking. if i don’t do this i can’t get a uniform shading. i’m using a tileable texture (roughcast)

blender

UE

Well yeah that’s not ideal!! If static lighting: Lightmaps can’t have overlapping areas!!
…it could work with the texture but…
I don’t know how UV mapping works in blender… You don’t have automatic flat mapping with a given angle?
This is not a difficult mesh to UV map to be honest… just select one side, flat map and scale down the inset parts a bit!
But I’m almost 100% sure there is some automated flat mapping if you don’t want to do it yourself…
Also!! When you import the mesh to Unreal you should have the option (even after importing “these days”!!) to let Unreal generate the UVs…

i think the problem comes from a bad UVing. you can’t see it on the images, but i made a bit complex glass bay on the building side, and i think the problem comes from there. i’ve been looking at the UVing and i noticed some not very catholic things. i’m gonna take back the mesh from zero as it’s not very complex, and i’ll simplify the bay, so the union doesn’t create too many small faces. i made a similar building once, and it textured flawlessly. i think the bay is the problem. i’ll make a multi meshs object if needed

Just answered a question in the content creation sections with some blender tips for UV lightmaps.

On this model, you could do a limited dissolve to clean up some of what you have there.

Open up a new texture for the UV. Set the image size to 1024 because it’s a a whole building.
smart uv project and see what you get.

ideally. Select the front face, after a limited dissolve and mark seams to get the windows separated from the main mesh.

And/or If you want the shadow to bend on the seam, select the inside plane of the windows, go into edge select mode, hit ctrl+1 and mark seams.
This should generate the seam that cuts out the window, and puts a cut on the window sill edges. Needed to clean the unwrap.

With the front face setup, make rest of the cuts to unwrap like a box. Dump the bottom plane if it’s got one. I’d probably delete the face. No need for it. And it can’t receive light, likely being underground.

With that done, unwrap into the lightmap and you should get a somewhat clean, straightened up UV.
I’d cut roof trimmings out too.
the plane facing the floor does need shadow in this case, but you can separate that trim entirely without much of a noticeable light artifact.
The AC units whatever they are, they can probably just unwrap but they’ll skew your US, mark a seam at their base. Also, pick a side and mark an edge, and separate the top plane on 3 sides to unwrap that.

When you unwrap after that you should get a mostly clean UV for light baking.
next thing would be to make sure thag the texel density of thebUV map matches the rest of the project.
is it necessary?? No… but when you look at the lightmap density visualization debug it’s really nice to see the same cubes across everything.

thanks for the help. i don’t need UV lightmaps, as i’ll go fully dynamic lightning. when i auto UV i get pretty good results. especially with the cube projection method. but i still have a sand grain with this

https://forums.unrealengine.com/core/image/gif;base64
​​
i pretty sure a have a too small, or overlapping UV somewhere. i’m pretty sure the whole problem is there

even with super clean mapping i can’t get that thing to work :rolleyes: