Using your own Unwrap for lightmapping

The default setup is “Source Index = 0 | Destination Index = 2”
I don’t understand the point of this at all. It just creates a 3rd UV channel, what a waste.
How do I make it so it just uses the UV unwrap I already did just fine on Channel 0?
I tried setting Source Index and Destination Index to 0, but that causes issues.

Turn off the lightmap generation, if you already have a lightmap in channel 1 then it’ll use it.
By default in the import options it will generate a new lightmap UV using channel 0


I’ve tried that as well. Here is what it does.

Overlapping? Really? Let’s have a look.

Doesn’t look like its overlapping at all. What settings did I use to pack them in 3d Studio Max?

There is no overlapping (that’s the point of the 0.02 padding).

In the mesh editor go to the details panel on the right > Static Mesh settings:

if you want channel 0 (your texture UV) to be your lightmap set it as such.

Next set the lightmap resolution you need.

Thank Tim, you pointed me exactly to where the issue was.

Here is where the confusion stems from for those suffering similar issues, and so maybe this can be made clearer in the future.

This checkbox is defaulting to 1, even though in all other cases the default is 0.
1 is baked tiling UVs, so clearly those DO overlap.

EDIT: Also, don’t use UV channel 0 for lightmaps. I thought you had to because it was showing up as the default on the other box, and I think because UDK used 0 as well.
But in UE4, if you put your textures on Channel 1, you then have to specify a texture coordinate node for every material that you place on the mesh, pain in the neck, not advised. :wink: