Download

Using Particles as a light source

Is there a way to get rid of the brightness over life option on a particle already made. I am trying to use the P_Fire particle from the starter content and I want the lighting to be static as the fire will never move outside of its natural flickering because of it being fire of course.

-------------OR-----------------

Does anyone know of a good tutorial I could look at for making my own basic particle that will allow me to make a fire that will server my purpose

Just delete or modify the module. :slight_smile:

Otherwise take a look at the particle documentation -> there you will learn how to create your own particle system: Cascade Particle Systems | Unreal Engine Documentation

well I have been trying to modify the module that is already there and even increased the bounding box of it to help with lighting but when I leave that box the light goes away. I don’t want that to happen. I want it to be the same amount of light generation from it regardless if I am 2 meters from it or 200 meters from it even up to 2000 meters from it. Also how do I stop it from showing threw walls into another room. I seem to have that issue though with not just the particles but also point lights

The easiest way will be to just delete the light modules + add 1 point light to the fire (either player it or create a blueprint with the fire and add it there) -> you wont get the flickering effect + you will get a better performance :slight_smile:

I would love to but for the ruins I am building I need the flickering or pulsing of the fire effect. The only thing I am having an issue with is it fading back to dark after I leave the bounding box. How do I by pass the bounding box?

Also I would post an image of what I am looking for but I am unable to get it to attach a file for some stupid reason. I have tried in multiple browsers.

if you are talking about a flickering light on your particle system, if you are using a GPU based particle system, then you could create a point light and toggle the visibility over and over again using blueprints, if you are using a standard Sprite particle system then when you create your light module on the Particle Emitter, turn the Spawn Fraction down until you get it to a good place that you want it until it looks good to you.

if you need any more help just ask.

–Matrix

I am using the defualt Fire particle P_Fire from the starter content. What happens is the when you are within its field of display the light will steadily get brighter but once you leave that it instantly goes back to the start of its cycle but stays dark til u enter the effected area again. I just simply want the fire to stay active regardless of being 2 ft from it or 200 feet from it.

I think what you mean is the eye adaption -> add a post process volume - search for auto exposure - set the min level to the max value and the max level to something that you want

Hi DragonMaster -

Fighter is correct you will probably want to change the Auto Exposure settings, but you can also turn off inverse Square behavior then you can manually set the falloff of the light in the Particle’s module.

I will give both of these a try and see what happens Thank you. Side note not related to this but important for you Eric since u are epic staff. The respawn of the player via a blueprint that is covered in the docs section seems to only fire once and then it wont work after that. I could be doing something wrong but I went over it a few times.