Using new materials freezes editor (OS X)

Every time I use a material I have never used before in a project, Unreal Editor will freeze for about 1 - 2 minutes. During this time, the editor is completely unresponsive and I have a spinning beachball cursor (I’m on a Mac). After a long time, it will finally unfreeze, and proceed to compile shaders.

This also applies to opening levels. If I open a level (like an included example level) that uses materials I’ve never used before in the project, the editor will freeze for about 2 minutes – per material! I just finished loading a level (Starter Map in the StarterContent folder) that took 20 minutes to load!

Everything else seems very fast and responsive. It only freezes if I have never used the material anywhere in the project – it will work fine even if I have used it in another level. Loading levels that I created, or that do not use new materials, is very fast. I’m also new to Unreal Engine, so I might be doing something wrong, but I’ve made sure to follow the instructions given in the tutorials.

I’m using Unreal Engine 4.7.2.

More information about my computer:

  • Late 2013, 21.5-inch iMac
  • OS X 10.9.5 Mavericks
  • 2.9 GHz Intel Core i5
  • 16 GB RAM
  • 1920 x 1080 display
  • Graphics: NVIDIA GeForce GT 750M 1 GB
  • 1 TB hard drive with 705 GB remaining space

Hey vantjac,

Would you mind providing me with your full system specifications?

Processor, Integrated Graphics, OS etc…

There are options within the Editor that can help improve your overall performance. In the Main viewport there is a dropdown that says ‘Settings’ which will contain the location of the ‘Engine Scalability’ settings.

Engine Scalability

Material Quality

Editing both of these settings will hopefully improve your performance. Let me know if this helped or if you need further assistance. This issue seems to be hardware related.


Thanks for the help. I added some information about my computer to my original post. I also decreased the quality of the settings you mentioned.

It’s getting harder to test the problem because I’ve used all of the example materials now, and it only freezes the first time I use them. I added a few new materials according to this tutorial, and they worked fine when I used them.
I might create a new project to see if the problem is still there.

Thank you for the extra information. Your system specs should be fine because we are using the same integrated graphics card as you. The processor we use is an i7 instead of the i5 so this could be some of the cause.

I was also informed the editor tends to run better overall in Yosemite, which is what we test on here as well. Yosemite 10.10.2.

Let me know what you discover.


I’ve upgraded to Yosemite, updated the editor, and lowered the quality, but it still freezes up when I create a material.

For some reason, it doesn’t always happen. When I create my own materials, it works fine. But I recently tried to migrate a material from ContentExamples (“Desert”), and it froze up again. Maybe it’s more complicated than the ones I’ve been making?

This is definitely the case. Especially if you are attempting to open a migrated material that is very complex and it is the first time opening in your project. It needs to load the texture samples as well as any material functions and properties that are set within.