Using make literal enum in BTTask_BlueprintBase causes problems

I created an enum and used make literal enum to use it in my BTTask_BlueprintBase. This caused the blueprint to have to be recompiled everytime the editor was opened and also caused the cooking to fail in 4.4. Removing this entire and just setting the value fixed both problems. Based on the error message I would maybe guess it’s related to an earlier bug report I filed.

13919-works+fine.png

Hey Amy,

I’m not getting this behavior when I feed a Literal enum into a Set Blackboard Value as Enum. Can you attach the output log after cooking fails? Are you in 4.4.0 or 4.4.1? Thanks!

Hi after an update from a team member it appears to be something else that was causing the cooking to fail. We’re using 4.4.1. Yeah I tried making a new project and it seemed to work so I’m not sure what I’ve done wrong in our current project.

Yeah it recompiles and works fine for the rest of the time the project is open. It’s just every time after first opening the editor and playing, it says the blueprint has an error and needs to be recompiled.

Does it recompile after that error appears, and does recompiling remove the error?

Hi Amy,

Sorry for the delay in response. We’re still not able to reproduce the issue you described, but I have seen another user with a similar issue recently. Does this only occur with custom enums? If you delete that enum asset and create a new one, replacing the reference to it in your blueprints, does the error recur? Let me know if you have time to test this for me. Thanks!

Hey Amy,

We haven’t heard back from you in awhile, so I am marking this post as resolved for tracking purposes. If you are still experiencing this issue after opening a copy of the project in 4.5, please feel free to reopen the post and we’ll continue investigating. Thanks!