Used persona to key new additive layer track and the newly keyed track does not show up in blendspace

I created a duplicate animation and I am trying to move the upperarm_l bone forward. I keyed and applied the new track. When I use the new animation in a blendspace the animation appears without the track. Is this by design? Or am I missing a step?

Having the same problem here…It appears that tracks are not taken into account when using a blendspace.

This problem is still happenning!! Also the same with anim montages…Any help from the Staff please?

That is odd. I’m sure you did “apply”? When you apply, it modified Raw Animation, which means every other operation should go through same way. This is not by design at all, and it should work. If not this is a bug.

So… it is a bug, because it is not working.

It is easy to reproduce:

  1. Take an animation
  2. add the track keys modifying the bones
  3. apply
  4. insert the animation to a BlendSpace or create a Montage
1 Like

Hi FilipeTessaro,

I’ve been testing this and I cannot find a bug here. I see what the original poster sees if I neglect to hit apply. However immediately after hitting apply, the additive key changes appear in the blendspace. Can you send me the content that this reproduces on? Preferably in a blank example project.


I’m having this in 4.15. Super reproducible for me. Still need the repro?

Hi Joe,

That’d be much appreciated!


Its happening to me, I made a montage from an animation that i edited and its not working

Do you have an asset or project that reproduces this consistently?

I stumbled across this very same issue in 4.15… :frowning:

As a work around
I had to edit my animations and tweak then in 3D application and brought it back into unreal.

Now blend space works as expected,But not with additive layer …

Is this bug or expected?

I m facing this issue too in my project with unreal 4.15.
I have created a project from a blank 3rd person and it works btw.

So I guess it doesn’t work in my project because of the re-targeting.
The retargetted animation is from the starter pack and I have re-targeted it
for a mixamo skele.

This occurs when checking EnableRootMotion check box in animation details and using the animation asset in blend space,When i tried unchecking EnableRootMotion the additive track appeared in blend space .

I am using UE 4.15.1.

(THIS DOESN T REALLY WORK, sorry… scroll down for a real workaround…)WORKAROUND (tested on 4.15)

  1. Open the animation (that you have duplicated or not)
  2. select a random bone and press the key button to key frame it. (This step is maybe not needed)
  3. Export the animation to FBX (with or without skeletal mesh)
  4. Re-import the animation.
  5. Now you can add key frames and everything is gonna work as expected.

In my case I see this issue when I use a mixamo character/skele (could it be because of the missing root bone?).
Layered animation works as they should (and confirmed by .) with the default unreal mannequin

I think I have found the solution. We need to name the bones in the same way they are called in the mannequin (default humanoid rig) in your favorite 3d software. Only retargeting bones don’t work. They need to have the same name.

Not really a solution, but nice that there is another workaround for this issue. :slight_smile: I have not chance to test it out.
BTW the problem is related to animation retargeting step.

I have just test this issure, just rotation can be keeped , trasformation can not be keeped into blendspace.

I had chance to test this again on 4.17.
This time I added a root bone to the mixamo skele and converted the mixamo animations to use the root motion using the blender plugin here (GitHub - enziop/mixamo_converter: Blender addon for converting mixamo animations to Unreal 4 rootmotion).
Keying mixamo and mannequin animations seems to work as a charm.

Two years later still no response from staff !?
ARE WE or AREN’T WE supposed to be able to use additive layer track in blendspace ??
It’s not even a request, it’s a question. Because of the lack of documentation, how are we supposed to know???