Used a material to stop weapon clipping, but disappears when I get too close to a wall

Hey all! Follows this youtube tutorial to make the material. Unfortunately I’m having an issue where the gun completely disappears when I’m face up on a wall.

I tried setting in the skeletal mesh, the Mesh, Positive/Negative Bounds Extension to ridiculous values, but the issue persists. Any ideas?

Try to enable “Use Attach Parent Bound” on weapon actor.

1 Like

That didn’t work, but googling that term did end up helping me find another thread which suggested I adjust the “Bounds Scale”.

This can be found (in my case) in the weapon blueprint, skeletal mesh component, Details panel, Rendering, Bounds Scale. Setting that to 2 fixed it. Thank you!