Download

"Use Emissive for Static Lighting" does not work...?

Hello there,

i want to use the “Use Emissive for Static Lighting” option but it dont gives me any effects.

My Setup is:

  • a static mesh with the use emissive for static lighting option turned on
  • a material with Material Domain “Surface” Blend mode “Opaque” and Shading Model “Unlit”
  • in this material is a color texture sample which is plugin into Emissive Color
  • the material is applied to the mesh
  • for testing i also increased the Emissive Bost in the static mesh to a value of “10”
  • optimal lightmap density options
  • the correct lightmap uv channel on

I baked light with all possible quality settings from preview to production but i never get any lighting results, regarding my static meshes. I also double check it with the view mode “lighting only” and “detailed lighting”.

For the light bake itself - it runs good and i dont get any errors or warnings.

I also checked my stuff with this video here - where i seems to work:

I hope you can help me because I really want to use this option/feature

Thanks a lot

Greetings

could you just show screenshoot of material and scene? Is there any other lights in it? Maybe just try it on something really simple, with no light, only glowing cube. Cos it should be like working “plug n play” with turning on “emissive for static…” . I;m not pretty familiar with meterial settings yet, but as I remember from my recent learning that it should work with default material. I;ve created simple color, mutipled it with value and plug to emmisive slot. Thats all and it always works.

Pictures of the result and the material layout would help.

I really dunno why you need any screenshots because i described everything and its a really simple setup … but heres a screen from my material. And for the result. I just have no results because nothing is happening

The emissive color looks to be too dark, but on top of that it might be because of the Unlit shading model.

I would first multiply your emissive texture so it’s brighter, and if that doesn’t do anything then change the shading model.

You’re lacking anything more than just the texture. Usually emissive doesn’t affect static lighting until it is at least a little bright. Try multiplying the texture output by a large number as a test. (The intensity of the light comes from the number values of your colors. Bolder colors give brighter light.) Check out the tutorial below for more.

Tutorial: Using the Emissive Material Input | Unreal Engine Documentation

I believe you also have to set some flags in the material as well as whatever mesh you put it on, or it won’t contribute to the lighting.

I don’t remember what they are called but if you scroll through the details panel, they are pretty easy to spot.

Edit: never mind, I just reread your post and it looks like you already did that. Sorry :confused:

If you’re texture is pure white, an emissive boost of 5 has the same power as a pointlight of the same size set to unitless 5. In most cases your texture is too dark, so emissive boost needs to be ramped up like crazy both in the material and the boost factor to actually contribute to the scene. It’s physically correct, so there’s some weirdness to it.

I’ve just ran some tests and discovered that “use emissive for static light” *will not produce light *if unless the mesh has cast shadow enabled. Seems counter-intuitive, as many times I like to have light source meshes not cast shadows so lights can be placed inside without being obstructed. It seems that lights are not blocked by one sided meshes, so perhaps that is a moot strategy, anyway. Will leave cast shadows enabled from now on, for emissive material meshes.

Also, sadly, it seems like this functionality only works for simple meshes… (not something which has multiple parts spread apart, and complex geo behaves erratically–crevices get more emissive response than the flat planes, etc.). Would only expect it to perform properly on cubes, planes (as a cheaper form of the rectLight, cones, spheres, etc.

Here is a primer on emissive lighting

In this configuration the intent is to cause the lighting to glow as well create a colour bleed as a light bounce. For the bounce to look right the surface the light bounces off must have a reflection value as part of the PBR material else the rendering engine will not know how much energy, intensity, the bounce surface needs to give off. A mirrored surface for example will have a hight reflective surface as compared to a brick or mud type surface.

The other use for emissive is to give off a light balance between the fore and back ground so the the lighting balance contrast does not look flat and can and is usually done as in your material example you have demonstrated.

Here is a demo I did back a bit that makes use of emissive lighting to increase materiel balance with out blowing out the environment GL lighting base.

The effect is best controlled through an instance of the material but the result is the object will have it’s own light level control built into the material with out having to resort or depend on lighting elements. A good example is Fortnite which I suspect uses a lot of self illumination type materials.

So depending on what you want to do emissive is a rather large brush but if you want a glow then the sum RGB will not work right for this type of configuration