Use - d3ddebug to enable the d3d debug device

I recently downloaded Unreal Engine 5 work amazing yesterday but today it crashed 3 times in less than about an hour. All the same error. Issues happened when I was testing on the 1st person shooter thing, specifically the animation of the arms. Any ideas on how to fix this issue or how to use d3ddebug? The full issue,
GPU Crashed or D3D Device Removed
Use -d3ddebug to enable the D3D debug device.
Check log for GPU state information.

Also, the category thing is annoying.

I experience the same thing: Unreal Engine 5, almost every project. Very random crashes. But constantly.
My graphics card, a 3080, always spikes one time, then there is this graph called copy, which also spikes. And then I get the error and unreal engine crashes. Please see the screenshot attached.
Anybody else having these spikes in the graphics card performance? There must be some way of protecting this from happen.

2 Likes

I also have the rtx 3080 and get the same crash constantly. I don’t know how to get to the graph after crashing but I will look into it to see if I get the same results.

2 Likes

Same issue here on 3090 with amd x3700 and 64gb dram.

2 Likes

We have 4 computers in our office that running Unreal Engine 5 with 3060, 2 x 3060 Ti and 3070 but all is getting constant crashes. We are tired of it please FIX IT!

2 Likes

So, the solution is?

Epic don’t help anymore, so its unclear what the best solution is - so try everything!
Read the other ~999 threads about this and try some of the ~999 possible solutions.
If none work then sue Microsoft, as Epic execs blame the problem on an OS change!
Interestingly, crashes like this didn’t happen until after UE4.18 (on both Win10 / Win7).
:wink:

I have the same problem, my computer configuration is Intel I7 12700 GPU RTX3080TI 32GBDDR4 3600

seems like there is no solution.
with 5900x, 3090, 128GB ram, no overclock,
crashes every ten minutes.
heavy foliage crashes UE very often.
but VRAM usage is like 8~9GB.

Same here, often happening with weird intervals in which sometimes it happens every 2 minutes, or every hour. Just happened when copying an object, all foliage turned off… Tried multiple “fixes”, none of them help.

I had the same problem and it turned out to be caused by RivaTuner. Sometimes is sufficient to close the MSI Afterburner app, but other times RIvaTuner would keep working in the background and it would need to be stopped from the Task Manager, Background Processes.

I hope this helps! All my UE5 projects would crash after a few seconds from loading up, apart for the “Demonstrating Animation Blueprints and AI for Gameplay Designers” project for some reasons.

7 Likes

Thx a lot man

1 Like

Gracias también me funciono

1 Like

It works for me! Thanks!!!

1 Like

This works for me too! Thanks!

1 Like

Muchas gracias!!!
Desactive el MSI Afterburner, y me funcionó normalmente Unreal 5.1

1 Like

I get the error when I go to open unreal engine and it shows the same error without me even getting on the software

So changing the renderer from DX12 to DX11 in UE5.1 worked for me.

In your UE project, go to project settings> search ‘RHI’> Platforms Windows> change ‘Targeted RHIs’ from DX12 to DX11

In a future where we can get results just by thinking about it - it must be boring.
Chat with AI can’t help this fix.
Thanks Bro.

In a future where we can get results just by thinking about it - it must be boring.
Chat with AI can’t help this fix.
Thanks Bro.