⚡ [ URGENT: New Update to UE5 Breaks Editor Completely] Crash in Megascans, every time I try to launch editor (Solution Found!)

Dear Epic & @SkyeEden,

The latest update to UE5 launcher version has broken UE5 completely, I cannot load the editor.

I was happily making my Rama Code UE5 Gift Project for the Community just moments before, but after updating, now I can’t do anything at all, editor will not launch.

I updated my NVidia Titan X GPU drivers, that did not help.

Windows 10,

But again, I was just using UE5, so I know my system specs are good to go.

Crash is in Megascans:

Assertion failed: (TTraits::WithIdentical || TTraits::WithIdenticalViaEquality) [File:E:\UnrealEngine\UE_RelTestA\Engine\Source\Runtime\CoreUObject\Public\UObject\Class.h] [Line: 1476]

0x00007ffab98fea59 UnrealEditor-MegascansPlugin.dll!UnknownFunction []
0x00007ffb095b0078 UnrealEditor-CoreUObject.dll!UnknownFunction []
0x00007ffb0958bfcb UnrealEditor-CoreUObject.dll!UnknownFunction []
0x00007ffb0982d87a UnrealEditor-CoreUObject.dll!UnknownFunction []
0x00007ffab98faa94 UnrealEditor-MegascansPlugin.dll!UnknownFunction []
0x00007ffb0984158b UnrealEditor-CoreUObject.dll!UnknownFunction []
0x00007ffab98fa81c UnrealEditor-MegascansPlugin.dll!UnknownFunction []
0x00007ffb09870bf3 UnrealEditor-CoreUObject.dll!UnknownFunction []
0x00007ffb09850191 UnrealEditor-CoreUObject.dll!UnknownFunction []
0x00007ffb09708245 UnrealEditor-CoreUObject.dll!UnknownFunction []
0x00007ffafd8ca5e2 UnrealEditor-Core.dll!UnknownFunction []
0x00007ffafd8ee957 UnrealEditor-Core.dll!UnknownFunction []
0x00007ffb1767aaf6 UnrealEditor-Projects.dll!UnknownFunction []
0x00007ffb1768de4a UnrealEditor-Projects.dll!UnknownFunction []
0x00007ffb1767a8b0 UnrealEditor-Projects.dll!UnknownFunction []
0x00007ff75e1d5451 UnrealEditor.exe!UnknownFunction []
0x00007ff75e1d866e UnrealEditor.exe!UnknownFunction []
0x00007ff75e1d0bbd UnrealEditor.exe!UnknownFunction []
0x00007ff75e1d0e8a UnrealEditor.exe!UnknownFunction []
0x00007ff75e1d3c4d UnrealEditor.exe!UnknownFunction []
0x00007ff75e1e5534 UnrealEditor.exe!UnknownFunction []
0x00007ff75e1e86e6 UnrealEditor.exe!UnknownFunction []
0x00007ffb5fc77034 KERNEL32.DLL!UnknownFunction []
0x00007ffb5fe82651 ntdll.dll!UnknownFunction []

This is the only intel on the subject I am aware of:

Dear @SkyeEden

Hi there!

I can’t install quixel bridge, I see this message:

The download was pending, but was not doing anything, so I cancelled so I could move on in the queue to downloading latest UE5 version, now I see this, I can’t use UE5 at all now

Please let me know what to do, I can’t load UE5 at all!

:tulip: All I can do now is dream about using UE5… sniff :rose:



PS: In case Mr Megascans who appeared in the UE5 Launch video on Tuesday sees this:

:rose: Awesome Job with Your Speech on Tuesday! :rose:

:rose: So inspiring! :rose:

:rose: And it was so nice to meet you and hear your story via the livestream! :rose:

I Looooove the idea of :zap: an app on a phone :zap: which can scan an object right into UE5 after cloud-computing processing occurs!

:sparkling_heart: Such a Beautiful Idea! :sparkling_heart:

:sparkling_heart: Rama

Hey! :slight_smile:

Can you check in your plugins folder for your engine (windows explorer) and see if you have Bridge or Megascans in that folder. If you do, it might be worth removing that.

We saw the “Install Failed” error that you are receiving during our reproduction steps- however, it resolved itself in about an hour. Have you restarted your system since then?

Let me know! Thanks!

i deleted the megascans folder in the engine plugins folder, restarted, and am in the process right now of reinstalling both epic games launcher from the latest installer and ue 5. i’ll let you know what happens.
one thing of note, is i appear to have “Bridge 2022.0.3” installed (i uninstalled bridge 2022.0.1 earlier), but I can’t uninstall it lol

i never recall installing bridge to my C drive. I do have an empty folder called Bridge at C:\program files\ though. I tried uninstalling and reinstalling the plugin via the quixel bridge installer as well today.

that’s a negative after reinstall still nothing in vault

Dear @SkyeEden ,

Wooohoo! That worked!

  1. I deleted bridge plugin (engine install not project level (for others reading this))

  2. I deleted the megascansplugin folder

  3. I can now load the editor!

  4. And yes, the other error I showed did resolve itself in about an hour like you said :sparkling_heart:

:rose::rose::rose:Thank you @SkyeEden !!!:rose::rose::rose:


I’ve followed up with you with a PM :slight_smile:

Huzzah! :smiley: I’m glad this worked for you! Happy developing! <3

1 Like

Hee hee! Thank You at @SkyeEden !!!

:zap: :sparkling_heart: I Love UE5!!! :sparkling_heart: :zap: