UPROPOERTY variables not showing in details

Hi, I´ve been trying to show some variable that I created in a C++ class and edited from the details of the object. So far I already try everything and still don´t get why they are not showing up.



Please if you need to know something just ask I will be ready to provide you with more details. Thanks

Looks like you are new here and playing around so i will assume you are not used to UE development

did you compile the project ?
if no, do it and it should be fine
else did you had the editor opened ?
if yes, you should check the output log windows to see if hot reload was successful
if hot reload was successful you should try to close the blueprint you are trying with and reopen it
else was build successful ( output panel of visual studio )

Hello Newest,

I am indeed new, everytime I make changes on the script I compile the project by clicking on the compile icon in the UE editor. Also I tried with the Blueprint closed, same. My proccess is like this:

  1. I create my C++ class. Then I compile the same way I told you before.
  2. I go to the Actor class and by right clicking I select Create Blueprint class based…
  3. Then I go to that new Blueprint, open it and try to find my variable in the details and by looking in all actions for this blueprint.

The last code I tested was the following:

Well, at the end I decided to make a new class and make the blueprint from it, now it works. I really do not see any differences between the classes but I happy now, than you.