Download

Uploading/Updating Existing Mod Error

Hey guys,

Got yet another frustrating uploader bug I’m having to stare down unless I want to re-upload a whole new version on the workshop…again. And I’m really not wanting to do that. Anyone know the fix to the following error?

That error occurs when you cancel an upload before it finishes on the workshop by hitting the cancel button by the way. Second time this has happened >.<

As always its greatly appreciated.

UPDATE: Problem solved as long as you manually change the ID in the VDF and the mod.db.

  • Sinari

Bump. This really needs to get patched.

Did you try using the Ark Mod Tools located in ArkDev/ModTools to upload your mod? I had a problem uploading through the DevKit so I just used that standalone mod tool after I cooked it within the DevKit, pointed to all the right files (ModDir,Map, put a title name etc). The Description I would advise to copy and save it somewhere as the standalone tool doesn’t work that well with it.

Had a problem with the DevKit steam upload tool updating my deathfind mod so I went to the standalone tool and updated it. (was giving me some stupid limit exceeded error when I was try to update it).

Give that a try and see if that works out for you instead.

That causes it to upload a new item

I assume you’ve seen in the new stickied post how you can edit your mods.db and edit the modid you are uploading to?

I had a skim through the sticky posts but couldn’t find anything.

But there are few more issues with cooking and uploading that also need to be called out:

  1. Storing the mod description in the PrimalGameData_BP and the Steam Uploader is both bad. For one thing, it’s confusing (which do I use), and secondly the single line of text overwrites the Steam description which is a far larger box with formatting uplift that doesn’t work. It would be great if mod name would be located in one place only… and mod description completely removed (it belongs in Steam, and only Steam).

  2. For newbies, the “Maps” text box in the Steam Upload is vague. It would be useful if there was a abbr. floating help text that said “This is the name given to your level”.

  3. There is a mod file disconnect between the Unreal Editor and Steam Uploader… and the game itself… .and Steam. For example, despite deleting Unreal Editor mod folders from disk they keep appearing whenever I start the editor. Even if they are deleted in the editor they always appear in the Steam Uploader anyway. Lastly, even when you delete the Unreal editor folder and the unsubscribe from the mod in Steam… these abandoned mods still show up in the game when you host your own session (you have to go into the Steam game Ark folder and manually delete it.

Anyway… it’s early access… so just calling this out to help :slight_smile:

The thread I was referring to was: ARK Dev Kit Update Notes! (Current: 222.6) - ARK: Survival Evolved - Unreal Engine Forums

  1. The Mod Description is a text field only for the pause menu (where you see all the server settings - it must be very brief) and the description data that gets uploaded are just parameters that a workshop upload accepts regardless of what game it is. The descriptions for what you type in the box are only saved in two locations as far as I know: mods.db and the vdf for the mod.

  2. The maps box is typically auto filled in if a umap was detected in the root folder of the mod, so honestly people should just leave it alone unless its behavior has changed recently. I wouldn’t say that the devkit is exactly designed for literally any person that owns the game to download, meddle around in things, and expect it all to work without research on how the tool is supposed to be used. Steam is steam, the devkit is largely UE4 with minor changes, and the workshop uploader is just an additional utility provided by the devs to simplify the uploading process. Technically you could perform the operations manually using steamcmd (which is what the uploader is using).

  3. The issue you are describing sounds like it has to do with you deleting files outside of UE4 and as such your mods.db file is incorrect. It can be accessed in a text editor here: steamapps\common\ARKDevKit\Projects\ShooterGame\Saved\Mods.db

Editing the ItemSeamID makes zero difference. It still uploads a new file.

Not that this is/will be of use but I noticed when they updated their primitive mod on Steam last night, they were able to update the original mod vs. posting a new one. Not sure what they did but in my opinion, it shows its possible. Maybe we need an official dev/mod team to shed light.

It is possible. It just requires not having ever canceled the upload before they had fixed the bug. I updated my old one many times until I hit cancel the one time cause I had forgotten to authenticate steam guard and had to.

Understood, thanks for the clarification!

False, I literally did this yesterday as I moved my files from my desktop to my laptop. My laptop wanted to upload my mod as a new id, I deleted that, edited mods.db to the old id, and it resumed using my old id once again. I also edited the VDF (which did nothing by itself), but shouldn’t have been necessary to do so.

I just tried it 3 times earlier. I’m just telling you my results. I wasn’t saying you didn’t experience success with this method. I didn’t edit the VDF at all (so maybe that is the difference), because I cannot find an ID anywhere in there.

EDIT: Found it in the VDF. Had looked earlier, but I guess in my rush to get things done before having to go out I didn’t notice it. That should show success after editing that as well.

For 1… yes understand it puts that info into the game for the pause menu. But it also totally overwrites the mod description on Steam. So that beautiful write-up you did for your mod on Steam: overwritten by a single line each time. The fix might be to just not have that single line get pushed to Steam.

For 2… I wouldn’t exactly call myself a newbie to modding, but I had some challenge getting a basic mod to work… and people will try to touch things to see if it “fixes” the issue. I realize now it’s best left alone… at the time I had changed it thinking I had missed a step. So it’s just some feedback to the devs that humans are humans.

For 3… I tried all the proper in-editor ways to remove/delete projects… but thanks for the heads up on manually editting the .db file that works.

On a related note… the SteamID creating a new mod every time… I don’t get that issue… I’m overwriting the mod every time as it should be.

Bump. I’m still having exact same issue as Jason now that I’ve tried to update my mod. It seems to be just refusing to use the replaced ID’s and wants to make a new .vdf every time with new over-ridden settings.

Clarification; Yes I edited the mod.db & the .vdf with desired workshop item ID I wanted to update. Also I even tried closing the Dev Kit and replacing the ID numbers again, then re-opening it to see if it was over-riding it because it was open. Didn’t fix anything.

For those interested in manual “fix” for the constant overwriting of the Steam mod description do this:

  1. Go to your \steamapps\common\ARKDevKit\ModTools folder
  2. Edit SteamVDF.template
  3. Remove line 8: “description” “%DESCRIPTION%”

Sinarisinestro, please put your frustrations aside and chill. I don’t see why you forget that I have responded to this thread multiple times and have detailed all the steps that were outlined by the devs. I have successfully tested this twice now, so there is likely just something in your mod development environment that is different. The best thing thing I can propose doing at this time:

  1. Navigate to SteamApps\common\ARKDevKit
  2. Backup and delete ModTools
  3. Verify the devkit
  4. Copy over the latest binaries and plugins from the github
  5. Open up the dev kit
  6. Open the mod uploader
  7. Select the mod
  8. Click reset publisher
  9. Close the uploader and devkit
  10. Navigate to SteamApps\common\ARKDevKit\Projects\ShooterGame\Saved
  11. Backup mods.db and then open it in notepad
  12. Find the line for your mod with a blank ItemSeamId
  13. Put the modid you want to use (must still exist in the workshop and have ownership to that ID) in the quotes
  14. Save and close
  15. Open the devkit, mod uploader, and try your upload (I don’t remember if the view on steamworkshop link is updated from the mods.db edit at first or until after the upload).

Otherwise maybe I could inject some steps for vdf modifications (outside of their obliteration that these steps currently perform) so let me know if that still doesn’t work.

Once you try another cook/push to Steam, you can edit \steamapps\common\ARKDevKit\ModTools\ModConfigs\YOURMODNAME.vdf
Then make sure “publishedfileid” has your Steam mod ID in there.

It might be worth doing a full re-install of the devkit from Steam, and re-adding the github engine.
I had this weirdness where I was getting 1fps / low frame rate in the Unreal Editor PIE… tried everything… eventually re-installed to fix.

I’m perfectly chill dude. Just pointing out that it’s a little excessive to be bringing this convo onto another platform or area that isn’t appropriate for it, continuing part of the discussion that had already been fully covered like it hadn’t ever, and then getting a bad attitude about it the entire time. You need to relax on the assumptions if anything, that’s where the problem is arising. (For those that are confused, this is in regards to him commenting on one of my Workshop items a number of times stating I could in fact fix this issue, doing what he stated, and I had tried a number of times in this exact thread before those comments)

I’ve tried these exact steps like 10 times now as well. Doing it anyways right now for good measure. And, no change…still. Idk how this is even being suggested still, it’s like you are just ignoring half the things I say Drathek.

You wonder why I am slightly hot & bothered at this point? Maybe it’s because you’ve suggested the same fix 5 times now in very slightly different ways, and yet insist that it’s something I’m just not doing right.

Again, in case it wasn’t made clear, I’ve tried these exact steps a number of times now (including just now as well), and STILL no change.

The definition of insanity is doing the same thing over and over again expecting a different result.

PS: I’m half tempted to make a joke about you working at Dell tech support, but I have a feeling you would take that personally the way things have been going lol

Honestly I am sorry you took offense to two statements but you may want to re-read them because there is no attitude behind them. Maybe it comes off very matter-of-fact but I am certain in my statements. There is however no mistake there is something going on with your responses and honestly I want no part in it.

The reason why I have given you similar steps to resolve your problem is because they outline everything I had to do personally. I have not only resolved the problem myself when I ran in to it initially and I went so far as to test it on an entirely different machine. In other words (to include my last series of steps I gave that seemed to only anger you) I am no genius to know exactly what you’ve done to that installation to get it to behave differently and don’t have The answer for you.

Please don’t take offense to this. I have put a lot of time in to trying to figure this out FOR YOU and to be honest no it was not worth it. I am sincerely sorry the problem still has not been resolved for you but all it has done is shown how little appreciation other people have for attempts to help. I have no further input for you and wish you the best of luck.