Upgrade to Windows 10 & 4.11: Cannot open include file: 'corecrt.h': No such file or directory

Hi. I recently upgraded my computer and laptop to Windows 10. I also upgraded my Unreal Project which had been working until now from 4.8 to 4.11 (which meant upgrading from Visual Studio 2013 to Visual Studio 2015.

My laptop builds no problem but my desktop fails to build and gives the error in the question title, as well as 400 other ones which I’m sure are related.

I saw that this issue was in 4.10 and has been addressed in 4.11: UniversalCRT include/library directories missing on project settings - Programming & Scripting - Epic Developer Community Forums

The thing is, there are two reasons why I can guess I’m having issues on my desktop and not my laptop

On my desktop: I upgraded from Windows 7 to Windows 10, and had (1) previous installs of Visual Studio 2008, and 2010. I also had a lack of space on my C: drive, so I (2) moved the folders ProgramData\Package Cache, Program Files\Microsoft SDKs and Program Files\Windows Kits to another drive and made a filesystem junction.

On my laptop: I did a clean install and had room on my C: drive so I didn’t move anything around.

So either (1) Old Visual Studio installations were messing up the library files, or (2) Moving the library files and using a filesystem junction were confusing unreal.
I tried uninstalling all of my Visual Studio installations and some of the libraries it came with (not all of them, wasn’t clear what to uninstall), and removed the files I moved to another drive, and reinstalled Visual Studio 2015. Didn’t fix anything.

Any suggestions?

So what fixed it was I created a new C++ project in Visual Studio and built it. I guess it updated the header files somewhere…I got the clue from: Missing CORECRT.H from the default include folder for VS215