Updated to 4.20, now I can't build

I switched over my project file to 4.20, and then selected Generate VS project files. Now, when I build, it fails on the first file in my solution. It says: cannot open source file “ActionMapInterface.generated.h”

But I did generate the project files. I’ve already tried deleting the Intermediate folder and re-generating the project files. Got the same error.

I also made sure to build in 4.19, and correct any deprecated code that showed up before switching over to 4.20. I really can’t tell what is going wrong, and I wish Epic gave us some better error messages or something. Right now it just says the build “exited with code -1” and …

UnrealHeaderTool failed for target ‘VR_Test_2Editor’ (platform: Win64, module info: C:\SynthStudio\Intermediate\Build\Win64\VR_Test_2Editor\Development\VR_Test_2Editor.uhtmanifest, exit code: OtherCompilationError (5)).

Any ideas?

Do you have visual studio 2015 or 17?

I have VS 2017.

I had this problem too. The Error List didn’t say much but looking at the Output tab showed an error not listed on the Error List.

LogCompile: Error: Pickup: Override of UFUNCTION in parent class (Pickup) cannot have a UFUNCTION() declaration above it; it will use the same parameters as the original declaration.

This particular error is a new change in 4.20 I believe.

Double check your Output tab in VS carefully if it shows any errors not shown in the Error List.

You saved my project. What is curious is that my output log didn’t show this error which is clearly an Unreal Header Tool issue. Perhaps my settings are not correct in order to display it. Thank you.