Unwanted holes in imported FBX mesh

Hello! So I’ve been working on a school project - trying to combine point clouds renders of a house, surrounded by mesh walls (with auto-collision) to create a game environment. So far I’ve had success with importing the point clouds using a UE4 plugin, but importing the meshes I made in Autodesk Maya has been a bit of an ordeal.

Here’s what the model looks like in Maya:

Solid, with no holes other than the intended stairway ports. However, when I export the model as an FBX and try importing into UE4, this is the result:

For some reason the imported mesh now contains holes that start from the intended openings and stretch towards the outer walls. I’ve placed a player in the scene and walked over these holes - though they it seems like you’d fall through, the mesh is solid and still contains collision. If the mesh was was going to be invisible this wouldn’t pose much of a problem, but I need the mesh to show in order to separate the various rooms of the point cloud.

I’ve tried various import settings (uncombined mesh / no auto-collision / etc.) but nothing gets rid of these holes. I’m new to UE4 so I’m sure I could be missing something simple, but I’m at my wits end trying to deduce what that might be. Any tips or suggestions on how to correct this import issue??

I appreciate any and all help, thank you!

Have you tried inspecting those faces in Maya?


As far as I get this it maybe worth trying importing the mesh directly to the engine, without the plugin, and in the import settings uncheck ‘Remove degenerates’. This feature removes ngons out of your mesh. Probably, that’s the reason.

1 Like

Yeah, the model was initially exported from Revit and I cleaned up the edges in Maya. The model in the pictures has no extraneous connections, just the edges and vertices necessary to create the various poly shapes.

Do you mean triangulation may be the cause, or that I should try to triangulate the faces to correct it? The original Revit model came pre-triangulated, but I thought deleting the unnecessary edges would save up some processing space - maybe that was a bad call?

I’ll try this once I’m back at my computer, thanks! Do you think I could import this way, then re-enable the plugin afterwards? Without it there’s no way to render the point cloud data. :S

Probably. I am not familiar with this plugin. First off, you have to define the reason of your problem. So, the most common reason for removing faces after importing the mesh to the engine is ngons (‘degenerates’) which the engine removes by default. If the reason is this then you would check if the plugin got options to change the way it imports the mesh.

Triangulating those objects in Maya then re-importing into Unreal fixed the issue!! I think there was an problem with smoothing groups, but I’m not exactly sure… Either way- it’s fixed! Thank you guys for the help!